Problems connecting even on Localhost

ZIYAD A. M. AL-BATLY zamb at
Thu Jun 2 12:53:38 UTC 2005

On Thu, 2005-06-02 at 20:18 +1000, Ken McLennan wrote:
> G'day there One & All,
> 	I'm not quite a newbie with Linux. I've been using it at home for some 
> years, but although I know a bit about how it works, I don't know enough 
> to solve my current problem.
> 	I connect to the 'net via dialup account and until a day or two ago, 
> all was fine. Yesterday I found that when using Hoary (I dual boot with 
> Win XP) I couldn't get a connection worthy of the name. For some strange 
> reason I found 40 - 70 bps to be just a tad too slow to be practical. To 
> be precise, it was so slow that sites were disconnecting before I could 
> load a page. Connections in Windows work fine, but I still can't get a 
> decent connect speed on Ubuntu. Hence the modem & ISP aren't the problem.
> 	I recalled that I had used Webmin to review the services begun at 
> startup, so I thought that perhaps I'd stuffed something up. (I don't 
> know what, but I thought I'd look for anything that even resembled a 
> modem or ppp setting). Lo & behold, I couldn't even get a connection to 
> localhost so no Webmin!! 	
> 	At least I've confirmed the fault is at my end, not my ISP's since I 
> wasn't online at the time =).
> 	However, that still doesn't help me sort out what the problem is. I use 
> yawmppp to connect, and it worked fine. The logs it produces show that 
> before connecting to my ISP there are several "crashes" as it calls 
> them. The graphic of the little bomb is very descriptive I guess. 
> However there don't seem to be any descriptions of what went wrong and I 
> don't really know where to look.
> 	I know it's more than likely that I stuffed up a setting, but I don't 
> know what. Any one have any ideas? Not only that, but how do I easily 
> reset whatever it is if I can't use Webmin?
> Hope to hear back soonish & thanks in advance,
> Ken McLennan
> Qld, Australia
To be honest, I have never used WebMin and I don't have the slightest
clue as to what cause the problem.  But I'll try to help.

See if you configured/created a Firewall in WebMin, run the following
and see what the output is:
        sudo iptables -n -L

>From another angle: If you want to undo anything from WebMin (or any
other package in Debian in that mater), remove the offending package
with the “purge” option and then reinstall it again:
      * In “Synaptic”, it's the option entitled: “Mark for Complete
      * In “dselect”, it's “_” (underscore).
      * With “apt-get” you need to pass the “--purge” option.

        But be warned:  By doing so, you erase *all* your configuration
        for that package, not just the options you don't want.  And
        there's no way to undo the damage once it's done (unless if you
        have backups of the configuration file(s) of course).


More information about the ubuntu-users mailing list