issues on setting up environment

Steve Torrefranca javacide at gmail.com
Wed Jul 20 04:39:15 UTC 2005


hello,

i was setting up our ubuntu test app server and i have j2sdk 1.5
apt-getted and installed at /usr/lib/j2sdk1.5-sun/

then i did export JAVA_HOME=/usr/lib/j2sdk1.5-sun/ from the command line
and jboss ran smoothly.   but after i closed the terminal and opened a
new one, JAVA_HOME was gone.

So I added "export JAVA_HOME=/usr/lib/j2sdk1.5-sun/" in /etc/profile and
did source /etc/profile command.  checked it with echo $JAVA_HOME and it
was again there.  but when i closed the terminal and open a new one (or
even just opening a new tab) it was gone!  isnt it supposed to be there
once you added it to profile or bash_rc?

so, we call it windwz hang over, i rebooted and tried echo command again
and it was still missing (with the export line in profile).

tried at my ubuntu laptop, same behavior. 

out of curiousity, and i hope no cats died, i tried it  with a debian
machine but it was okay.

am i missing or messing something?

thanks

steve



Steve Ong Torrefranca
http://www.on-tvmall.com.tw

-
my ubuntu E17 rocks that even Mac OSX would look like Win 3.0 beside it







More information about the ubuntu-users mailing list