issues on setting up environment

Matthew S-H mathbymath at
Wed Jul 20 05:00:23 UTC 2005

On Jul 20, 2005, at 12:39 AM, Steve Torrefranca wrote:

> hello,
> i was setting up our ubuntu test app server and i have j2sdk 1.5
> apt-getted and installed at /usr/lib/j2sdk1.5-sun/
> then i did export JAVA_HOME=/usr/lib/j2sdk1.5-sun/ from the command  
> line
> and jboss ran smoothly.   but after i closed the terminal and opened a
> new one, JAVA_HOME was gone.
> So I added "export JAVA_HOME=/usr/lib/j2sdk1.5-sun/" in /etc/ 
> profile and
> did source /etc/profile command.  checked it with echo $JAVA_HOME  
> and it
> was again there.  but when i closed the terminal and open a new one  
> (or
> even just opening a new tab) it was gone!  isnt it supposed to be  
> there
> once you added it to profile or bash_rc?
> so, we call it windwz hang over, i rebooted and tried echo command  
> again
> and it was still missing (with the export line in profile).
> tried at my ubuntu laptop, same behavior.
> out of curiousity, and i hope no cats died, i tried it  with a debian
> machine but it was okay.
> am i missing or messing something?

not really an expert on this, but try adding this to your /etc/profile:
export JAVA_HOME

Hope that helps.
If not, I'll pass the buck on to someone who knows better.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2149 bytes
Desc: not available
URL: <>

More information about the ubuntu-users mailing list