[ubuntu-us-nm] Ubuntu Server and Joomla Permissions Issue

Kurt von Finck mneptok at mneptok.com
Fri Sep 25 22:10:55 BST 2009

On Fri, 25 Sep 2009 10:43:37 -0600
David Einerson <deinerson1 at gmail.com> wrote:

> Hello all,
> I have Joomla 1.5.14 installed and running nicely on an Ubuntu 9.04
> server. The server is fully patched and up-to-date.
> The trouble I am having is that when I go to install a Joomla
> Extension/Module/Plugin, etc the "inherited" file and directory
> permissions only allow the user to read and write, which causes the
> install to either fail or then require manual intervention to correct
> the failed install.
> How do I get the file and directory permissions to be rw-rw-rw for
> user, group, and other during installation. For example: I install
> CiviCRM, which creates a few directories and lots of files in the
> Joomla subdirectories. But because the inherited file and dir
> permissions are user rw only, the install doesn't complete - CiviCRM
> can't run the SQL script to create data tables because it doesn't
> have access to the newly created files and directories.
> I have tried numerous "fixes" including:
>    - sudo chmod -R g+s /var/www/joomla15
>    - sudo chmod -R o+s /var/www/joomla15
> These look like they should work, but perhaps I am missing a step or
> a few. BTW, I ran the above commands *before* attempting the install.
> Currently the Joomla file structure owner and group is root and once
> group and other get rw permission it works (minus db tables). Do I
> need a special owner and/or group with proper permissions to inherit
> from?
> Note: I can correct the permissions after the fact, but this only
> works when the Joomla extension is created in a way that makes it
> possible. For example, some extensions create database tables
> directly from PHP during installation, so the extension just won't
> work - without *a lot* of hoop jumping. For extensions like CiviCRM,
> the install PHP uses a SQL script to create tables, which I can
> manually execute after the fact. But, of course, this is a pain, when
> I know it should work seamlessly during install.
> Any help with this "inherited" permission issue would be greatly
> appreciated. I have been banging my head against it for a week.

You will probably want to change the umask for the Joomla user to 2.
This means that any files created by the Joomla user are set


and any directories created by the Joomla user are set


You can set this in the .profile / .bashrc / other of the Joomla user.
Then ensure that any relevant users are in the Joomla user's default


kurt von finck


public key: keyserver.ubuntu.com
key id: 5229D26A
fingerprint: 127A A484 ADBF A5AD E7FB 8CD2 8913 18F4 5229 D26A

Music is the space between the notes. - Debussy

More information about the ubuntu-us-nm mailing list