No audio - was: Real time for Ubuntu Studio 10.04 amd64

Gerhard Lang lang.gerhard at
Wed Jul 28 23:18:48 BST 2010

Am 28.07.2010 18:22, schrieb Ralf Mardorf:
> Hi :)
> today I tried Ubuntu Studio again, but I had no time to work on the
> realtime kernel issue, because I got some new issues.
> 1.
> After updating apps and the non-realtime kernel, my manually edited
> grub.cfg was automatically overwritten by a completely grotesque
> grub.cfg, without an automatically backup of the original. So tomorrow
> I'll have to do a hard job to make all my really existing kernels and
> Linuxes bootable again and those who are already bootable needs to get
> rid of those annoying boot splashes, unfortunately I didn't backup it
> myself.
> 2.
> I tried to play a MP3 by Movie Player, the PA setting meters show
> output, optional for one or the other of my two Terratec EWX 24/96 sound
> cards, but there was no sound hearable or visible for Envy24 control.
> 3.
> I installed KMPlayer, set it up to use JACK, run JACK, launched
> KMPLayer, pushed play and play stand still.
> Any hints how to solve issue 2 and 3 are welcome.
> Cheers!
> Ralf
hi Ralf
I'd recommend grub2. On my stationary machine it finds all hard-drives, 
partitions, oses and every single Linux kernel. You'll just have to edit 
/etc/default/grub for your needs on the Linux from where you updated 
grub i.e. for getting rid of splash and recovery mode, setting defaults 
I also have an ice1712 card, a hoontech dsp24, and it worked ootb in 
10.04 64bit.
But just in the moment I have problems with sound/alsa in kernels and 24 generic and preempt.
With rt kernel and jack2 (available i.e. in falktx ppas) 
and  alsa updated to 1.0.23 all audio is fine.
Even if both your cards are selectable in PA I think your problem has to 
do with multiple sound-card setup which seems to be not trivial in 
Ubuntu. Can you select them  in Qjackctl too?
good luck

More information about the Ubuntu-Studio-users mailing list