PPA report & questions

Khashayar Naderehvandi khashayar.lists at gmail.com
Mon Feb 2 12:21:19 GMT 2009

On Mon, Feb 2, 2009 at 12:57 PM, suemac at empire.net <suemac at empire.net> wrote:
> I have upgraded UBS hardy via Khashayar's PPA in launchpad.
> I chose all the alsa stuff, ardour, audacity, ffado, and pulse.
> So far it looks like everything is functioning and nothing broken.
That's good to hear. Although, keep in mind that my PPA is not
supported by the ubuntustudio team, and it's really an
on-your-own-risk venture you're undertaking. The ppa has had little to
no testing (I'm gonna keep on reminding everyone about this ;-)).

> Questions though:
> - The guys over on Jack irc say alsa_in and alsa_out should be with the
> latest Jack. I can't find them...
I'm not sure about this.
To minimize the risk of having broken packages, I try to follow the
packaging done in the current development release of Ubuntu, as far as
possible. That means that the jack packages in the hardy section of my
ppa basically are built the same way jack in jaunty is, with
additional libffado support. Do you know if there are additional
dependencies needed to get alsa_in and alsa_out? I might consider
adding them to the package.

> - What do I need to install to get Audacity to use Jack. Again, I was led
> to believe it came with the latest Audacity.
Audacity should work with jack through portaudio. Make sure jackd is
running before you fire up audacity. At least it works here.


More information about the Ubuntu-Studio-users mailing list