Non-coder contribution: hardware testing

Ricardo Lameiro ricardolameiro at
Thu May 27 13:33:40 BST 2010

ok, lets see if your computer /kernel can "see" the cd drive.

please issue the following command on you home folder :

$sudo lshw > hardware.log

if you dont have lshw, just do $sudo apt-get install lshw

lshw is a tool that list all the hardware components in you computer, from
here we maybe can have some point to start off.

Explanation of of the command:

Sudo - run the following command as a super user

lshw - list hardware devices

> hardware.log  - outputs the information to a file (hardware.log), instead
 of outputting it to the screen (stout).
You can run this command and check the results on the CLI screen.

After that attach the file and we will see then.

2010/5/27 Paul DeShaw <pauldeshaw at>

> Date: Tue, 25 May 2010 11:23:04 +0100
>> From: Ricardo Lameiro <ricardolameiro at>
>> Subject: Re: Non-coder contribution: hardware testing
>> To: "Ubuntu Studio Development & Technical Discussion"
>>        <ubuntu-studio-devel at>
>> Message-ID:
>>        <AANLkTikZ7XUu4vT5QTLSD--Aj6fI4cBItWwI7IeurWos at>
>> Content-Type: text/plain; charset="iso-8859-1"
>> Ok lets try to go somewhere,  I dont understand what is happening but i
>> searched on the internet and found this
>> <
>> >maybe
>> a possible solution (firmware update)
>> <>Is the drive on an
>> external enclosure or internal? did you tried to do a manual mount of the
>> drive?
> Hi,
> Could not find the right firmware on either of those sites; I could not
> figure out how to search the first one.  I have also tried HP's site.  If it
> was a firmware issue, would  generic Ubuntu be able to run the drive?  I
> booted a USB stick of 10.04 over the weekend and was able to detect the
> drive and play a CD--though there was no audio.
> It is mounted internally, plugged into the IDE cable.  The jumper is set to
> "slave".  There is nothing else on its channel.  The BIOS detects it.
> I do not know how to mount it as it doesn't have a mount point that I can
> find.  I'm not too skilled with the command line, but when I use the GUI,
> Places does not have an item for CD or DVD.  Places>Computer opens a file
> browser window that lists only floppy0 and File System.  Of course there is
> no floppy, "special device /dev/fd0 does not exist".  Under Karmic, there
> used to be a listing, but it wouldn't open; it showed the error "special
> device /dev/sc0 doesn't exist".  Now in Lucid there is nothing to click on.
> ls /dev confirms no /dev/sc0.  ls /media outputs
>  floppy floppy0
> Are there any other terminal commands you would like to see the output of?
> Thanks,
> PD
> --
> Ubuntu-Studio-devel mailing list
> Ubuntu-Studio-devel at
> Modify settings or unsubscribe at:

Fagote / Contrafagote
Bassoon / Contra-bassoon
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Ubuntu-Studio-devel mailing list