libssl0.9.7 depends on non-existent libc6 >= 2.4-1 (dapper)

Grötzner, Frank Frank.Groetzner at
Mon Oct 22 09:42:19 BST 2007


my libssl0.9.7 on Ubuntu 6.06.1 LTS depends on
libc6 >= 2.4-1 which is not available for install:

------------------- SNIP -------------

Package: libssl0.9.7
New: yes
State: installed
Automatically installed: no
Version: 0.9.7k-3
Priority: optional
Section: universe/oldlibs
Maintainer: Ubuntu MOTU Developers <ubuntu-motu at>
Uncompressed Size: 5308k
Depends: libc6 (>= 2.4-1), debconf (>= 0.5) | debconf-2.0
Conflicts: ssleay (< 0.9.2b), libssl, openssl (< 0.9.6-2), libssl096-dev (< 0.9.6-2)
Description: SSL shared libraries
 libssl and libcrypto shared libraries needed by programs like apache-ssl, telnet-ssl and openssh.

 It is part of the OpenSSL implementation of SSL.

------------------- SNAP ----------------

And here the available libc6:

------------------- SNIP -----------------

Package: libc6
State: installed
Automatically installed: no
Version: 2.3.6-0ubuntu20.5

-------------------- SNAP ----------------

This results in:

-------------------- SNIP -----------------

Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following packages are BROKEN:
  krb5-user libssl0.9.7
The following packages will be upgraded:
3 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 5691kB of archives. After unpacking 139kB will be used.
The following packages have unmet dependencies:
  krb5-user: Depends: libc6 (>= 2.5-0ubuntu1) but 2.3.6-0ubuntu20.5 is installed.
             Depends: libkrb53 (= 1.4.4-5ubuntu3.3) but 1.4.3-5ubuntu0.6 is installed.
             Depends: libkadm55 (= 1.4.4-5ubuntu3.3) but 1.4.3-5ubuntu0.6 is installed.
  libssl0.9.7: Depends: libc6 (>= 2.4-1) but 2.3.6-0ubuntu20.5 is installed.

----------------------- SNAP ----------------------


More information about the Ubuntu-motu mailing list