fai-kernels package

Henning Sprang henning_sprang at gmx.net
Sun Mar 19 23:45:21 GMT 2006

Hi Xavier, thanks for this report, I'll see what I can do about these things.

Some comments/questions:

On 3/18/06, Xavier Claessens <xclaesse at gmail.com> wrote:
> [...]
> 1) dhcp3-script, solved by removing the </dev/null on the end of the
> apt-get command to have interactive mode and answered "yes" to the
> question. I didn't tested your package yet, but I don't know if it is a
> good solution since dhcp3-client is in the list of packages to install
> in the nfsroot... so if --execpt option of debootstrap remove
> dhcp3-client it will be installed back just after.

The thing you are talking about, just having dhcp3-client in the
exclude option for debootstrap is not what I did with the fai-bfsroot
package, this would only require changing a config file.

I made a different change, which would require some more fixing.

>  I think the good
> solution is to make apt-get accept automaticaly to overwrite the config
> file (don't know how). Is the modification of the package fai-nfsroot
> needed ??

This _should_ be done with dpkg-divert, and Thomas Lange, the Debian
maintainer of FAI said, the uses dpkg-divert in fai-nfsroot. I did not
check that back yet.

> 2) the bootfloppy has the "savedefault" line in menu.lst, It causes a
> "Error 15: file not found" error just after loading the kernel from the
> boot floppy. I removed the line and it boots.

How does you menu.lst look like? (I did not use the bootflopy since ages)

> 3) pcnet32 module has a little bug in kenrel < 2.6.15 so I have to
> manually set it to 100Mbps full duplex with mii-tool (by default it set
> up at 10Mps half-duplex). If fai-kernels is updated to 2.6.15 this
> problem will be solved.

Is this only for installation, or in the installed system, also?
I'll forward this to the fai-kernels maintainer.

> 4) cfengine segfault, I think it is a problem of the ubuntu package. But
> it isn't very important, client works without "scripts/FAIBASE/40-misc"

Is this the only cfengine script that segfaults? Which version of
cfengine is oin your nfsroot? (I have some vague idea that there was a
problem with cfengine 2 scripts, so if Ubuntu doesn't have cfengine 1
anymore, we might not be able to make a decent FAI for Ubuntu until we
managed the transition to cfengine 2.

> 5) nfsroot is mounted readonly, so /dev/ is readonly so udev can't make
> files needed for the hardware (/dev/hda* /dev/sda*) so I created them
> with MAKEDEV in the nfsroot. udev is installed in the nfsroot,
> debootstrap install it.

At least running makedev explicitly could be included in
make-fai-nbfsroot instead. I remeber that I had these troubles, too,
when trying to use FAI on an Ubuntu server. I did not work further on
it since I do not use Ubuntu on servers so I have  no Ubuntu server,
and no Ubuntu Fai Server. I like Debian stable for servers.

> I install some packages on the client that need
> to add a device file and it fails because it is mounted readonly...
> don't know how to solve that problem.
> [...]

Which packages are failing, exactly? For FAI in Debian I never heard
of such problems.


More information about the ubuntu-devel mailing list