fai-kernels package

Xavier Claessens xclaesse at gmail.com
Sat Mar 18 17:14:19 GMT 2006


Le samedi 18 mars 2006 à 17:19 +0100, Henning Sprang a écrit :
> Hi,
> 
> On 3/18/06, Xavier Claessens <xclaesse at gmail.com> wrote:
> > [...]
> > I currently have a dapper FAI server and I can install dapper clients
> > using FAI without any kernel problem. But I had kernel problems when
> > installing Breezy.
> 
> With the new fai-nfsroot package I sent you? But you must have made
> some more changes, right? Please let me know, what it was altogether
> that you had to change to get it going, and I'll make a package that
> includes those changes, maybe we'll gte them into dapper if somebody
> can upload them.
> 
> I checked the status of the fai-kernels package, it's not yet
> obsoleted, it's neede, I assume with your successful installation you
> took it from somewhere else, right?
> 
> So we need some help from some other developer on how to get the
> fai-kernels package back into Ubuntu, synched from Debian unstable.
> 
> Henning

I downloaded and isntalled fai-kernels
(http://www.informatik.uni-koeln.de/fai/download/fai-kernels_1.10.1_i386.deb)

Problems:

1) dhcp3-script, solved by removing the </dev/null on the end of the
apt-get command to have interactive mode and answered "yes" to the
question. I didn't tested your package yet, but I don't know if it is a
good solution since dhcp3-client is in the list of packages to install
in the nfsroot... so if --execpt option of debootstrap remove
dhcp3-client it will be installed back just after. I think the good
solution is to make apt-get accept automaticaly to overwrite the config
file (don't know how). Is the modification of the package fai-nfsroot
needed ??

2) the bootfloppy has the "savedefault" line in menu.lst, It causes a
"Error 15: file not found" error just after loading the kernel from the
boot floppy. I removed the line and it boots.

3) pcnet32 module has a little bug in kenrel < 2.6.15 so I have to
manually set it to 100Mbps full duplex with mii-tool (by default it set
up at 10Mps half-duplex). If fai-kernels is updated to 2.6.15 this
problem will be solved.

4) cfengine segfault, I think it is a problem of the ubuntu package. But
it isn't very important, client works without "scripts/FAIBASE/40-misc"

5) nfsroot is mounted readonly, so /dev/ is readonly so udev can't make
files needed for the hardware (/dev/hda* /dev/sda*) so I created them
with MAKEDEV in the nfsroot. udev is installed in the nfsroot,
debootstrap install it. I install some packages on the client that need
to add a device file and it fails because it is mounted readonly...
don't know how to solve that problem.

That's all. Thanks.

Xavier Claessens.




More information about the ubuntu-devel mailing list