Vlc won't play DVD's on Ubuntu, or Kubuntu Intrepid

Nigel Henry cave.dnb2m97pp at aliceadsl.fr
Tue Feb 3 17:23:40 GMT 2009


I have vlc installed on both my Ubuntu, and Kubuntu Intrepid 8.10 installs, 
but vlc will not play dvd's. It finds the optical drive ok, and I get the 
menu up for the dvd, but only about a half second of sound, and video play, 
then it stalls. If I press on play the movie, again I get about a half second 
of sound and video, then the movie stops playing. If I move the progress bar, 
I can move through the movie, but again when I stop moving it, another 
snippet of sound and video, and all I have is effectively a still shot, with 
no sound.

All this time the progress bar is moving it's way through the movie, the time 
is progressing, I see harddrive activity (as you get when a dvd on another 
distro is playing ok), and the light on the optical drive is blinking on and 
off, every half second or so.

Both Kaffeine, and Xine play dvd's ok on Kubuntu Intrepid, and Totem, and Ogle 
play them ok on Ubuntu Intrepid.

On the same machine, Fedora9 has vlc 0.9.8a Grishenko, and Archlinux uses the 
same version, and they both play dvd's ok. The only difference being that 
Fedora is using the radeon video driver, and Archlinux the ati one, but both 
Intrepid installs are using the vesa driver.

I downloaded the 0.9.8a version from the videolan site, and built it on 
Kubuntu Intrepid, but with the same result as the 0.9.4 version.

I then enabled the Hardy Multiverse repo, and installed the Hardy version of 
vlc 0.8.6a janus (wxWidgets Interface) on Kubuntu Intrepid, which plays dvd's 
with no problem.

I know vlc is from the muliverse repo, but has anyone any idea as to why I'm 
getting this problem with the 0.9.4 qt version of vlc on Intrepid.

Thanks for any suggestions.

Nigel.




More information about the Ubuntu-devel-discuss mailing list