Problem with yum etc after installing Ubuntu 7.10.....

Forest Bond forest at alittletooquiet.net
Thu May 15 17:12:24 UTC 2008


Hi,

On Thu, May 15, 2008 at 01:01:14PM +0800, Peter Teoh wrote:
> a.  install ubuntu
> b.  apt-get install yum*
> c.  apt-get install git
> 
> Next I tried "git", I got "command not found", but reattempted to
> "apt-get install git" will give me:

Try:

  apt-cache show git
  dpkg -L git
  apt-cache search git

This might have made you aware that you need package git-core, not package git.
Also, I don't know about you, but when I type git, I get:

  $ git
  The program 'git' is currently not installed.  You can install it by typing:
  sudo apt-get install git-core
  bash: git: command not found

> I tried to yum install some other stuff, I got the following:
> 
> There was a problem importing one of the Python modules
> required to run yum. The error leading to this problem was:
> 
>   No module named cElementTree
> 
> Please install a package which provides this module, or
> verify that the module is installed correctly.

Well, you need package python-celementtree.  It sounds like there's a bug in the
yum package, as it should obviously have a dependency on this package, and
doesn't.

So:
 
  apt-get install python-celementtree

And:

  https://bugs.launchpad.net/ubuntu/+source/yum/+filebug

Anyway, why on Earth are you installing yum?  I think you'll find that APT is
generally a better choice on Debian/Ubuntu.

> It's possible that the above module doesn't match the
> current version of Python, which is:
> 2.5.1 (r251:54863, Oct  5 2007, 13:36:32)

Which is not an issue on Debian/Ubuntu, as we have two competing systems that
solve this problem (python-support, pycentral).

> Can someone help?

Hope this helps, however, in the future you probably ought to take support
requests to ubuntu-users.

-Forest
-- 
Forest Bond
http://www.alittletooquiet.net
http://www.pytagsfs.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-devel-discuss/attachments/20080515/5f0fc821/attachment.pgp>


More information about the Ubuntu-devel-discuss mailing list