kill switch on with intel wifi 4965

(=?utf-8?q?=60=60-=5F-=C2=B4=C2=B4?=) -- Fernando ubuntu at bugabundo.net
Thu May 15 20:14:57 UTC 2008


I'm sorry to bring "noise" about Hardy, on a list now meant to Intrepid, but unable to find how to fix this in any other way, so if any dev could lend me an hand it would be great. I know this is not Ubuntu fault, but manufactors, but still, I know we can fix this.

I've bough a new laptop (an ASmobile S37S, asus barebone) that has an Intel 4965 ABGN.
I've search ubuntu foruns, lp, and googled all I could, but am unable to make the kill switch off, in order to turn the wifi on.
The card is well identified by the kernel, but there is no way to make it seen to NetworkManager, or even turning on the led.

Also when I tried to use ndiswrapper, it cause a back trace during the boot, and I was forced to use the LiveCD to uninstall it.

$ uname -a
Linux BluBUG 2.6.24-17-generic #1 SMP Thu May 1 13:57:17 UTC 2008 x86_64 GNU/Linux
$ sudo rmmod iwl4965
$ sudo modprobe iwl4965
$ sudo lspci | grep 4965
04:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)

is this in anyway related?
http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1209
[quote]
 ------- Comment #44 From Jack Malmostoso 2008-01-22 03:00:28 -------

I have installed 2.6.24-rc8 from the Debian trunk tree (http://wiki.debian.org/DebianKernel) and while leds do not work, the kill switch is now set to "0". It is still not possible
to toggle it but at least now
wireless works.
[/quote]

https://bugzilla.redhat.com/show_bug.cgi?id=240116#c4

Comment #4 From John W. Linville on 2007-05-15 14:58 EST
[quote]
Looks like iwl3945 is not polling SW-based RF kill switch. Please try this:
   echo 0 > /sys/class/net/wlan0/device/rf_kill
[/quote]

before this I need to remove and re-add the iwl4965 module

after the echo NetworkManager sees the wifi, but ifconfig doesn't.

I've installed boot chart to see if I could track down the problem. You can see the result here:
http://fileland.bugabundo.net/Linux/hardy-20080513-1.png

It seems that the Led turns of when X starts, so my guess is that some RC script is turning off the led and/or on the kill switch.

I've open a LP ticket for this:  https://bugs.launchpad.net/ubuntu/+bug/230844

Any help is appreciated.

Thanks in advance.

-- 
BUGabundo  :o)
(``-_-´´)	http://Ubuntu.BUGabundo.net
Linux user #443786    GPG key 1024D/A1784EBB
My new micro-blog @ http://BUGabundo.net
ps. My emails tend to sound authority and aggressive. I'm sorry in advance. I'll try to be more assertive as time goes by...
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part.
URL: <https://lists.ubuntu.com/archives/ubuntu-devel-discuss/attachments/20080515/412ccb70/attachment.pgp>


More information about the Ubuntu-devel-discuss mailing list