Problem with yum etc after installing Ubuntu 7.10.....

Scott Kitterman ubuntu at
Thu May 15 05:15:40 UTC 2008

On Thu, 15 May 2008 13:01:14 +0800 "Peter Teoh" <htmldeveloper at> 
>a.  install ubuntu
>b.  apt-get install yum*
>c.  apt-get install git
>Next I tried "git", I got "command not found", but reattempted to
>"apt-get install git" will give me:
>root at oracledaddy:/tmp# apt-get install git
>Reading package lists... Done
>Building dependency tree
>Reading state information... Done
>git is already the newest version.
>0 upgraded, 0 newly installed, 0 to remove and 211 not upgraded.
>I tried to yum install some other stuff, I got the following:
>There was a problem importing one of the Python modules
>required to run yum. The error leading to this problem was:
>  No module named cElementTree
>Please install a package which provides this module, or
>verify that the module is installed correctly.
>It's possible that the above module doesn't match the
>current version of Python, which is:
>2.5.1 (r251:54863, Oct  5 2007, 13:36:32)
>[GCC 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)]
>If you cannot solve this problem yourself, please send this
>message to <yum at>.
>Can someone help?

Yum needs to be updated to work with Python 2.5.  Python 2.5 includes 
celementtree.  We have a separate celementtree package in the archive for 
use with Python 2.4.

I'm not sure why you'd bother with Yum in a Debian derived distribution, 
but if you run Yum with Python 2.4:

: python2.4 /path/binaryname

I'd guess it would work through that problem if celementtree is installed.

Scott K

More information about the Ubuntu-devel-discuss mailing list