D-Link and Ndiswrapper

earth walker earth_walker at hotmail.com
Tue Dec 19 20:19:53 UTC 2006

No problem, I'm happy that it helped!

>From: "Tee Jay Rosene" <teejayrosene at gmail.com>
>Reply-To: The Canadian Ubuntu Users Community <ubuntu-ca at lists.ubuntu.com>
>To: ubuntu-ca at lists.ubuntu.com
>Subject: Re: D-Link and Ndiswrapper
>Date: Mon, 18 Dec 2006 21:58:34 -0500
>Brendan, your information is the best feedback ever! I'm happy, no I'm
>ecstatic, to report that I'm writing this email and sending via my wireless
>I've been trying to get this card going off and on for about a year, with 
>always plaguing the back of my mind. It was just one of those things I was
>determined to figure out.
>I don't want to even imagine how many hours I've spent researching and
>looking for a solution on the net.
>Of course there were many answers, some of them drawn out and elaborate, 
>nothing worked. Now your response has made it so easy.
>I started out trying to get it going on 5.10, then 6.06, all to no avail.
>Then I thought I'd find a solution in 6.10. Now I have instructions for
>Anyway, I owe you a pitcher or two. If you're ever in the Sudbury area,
>definitely let me know.
>Hi, Tee Jay.
>>Which version of Ubuntu are you using? Many of the D-link adapters
>>work in Ubuntu without the need for ndiswrapper. Ndiswrapper should be a
>>last resort only for cards known not to work in linux. Unfortunately much
>>the documentation seems to points users towards it unnecessarily.
>>If it is one of the Dlink cards based on the Atheros chip (my AirPlus is)
>>should work out of the box in Dapper, while in Edgy you need to install
>>restricted modules for your kernel version.
>>I would start with the assumption that it works (since it does on mine).
>>the first thing you should do is remove the ndiswrapper stuff completely.
>>If you're on Edgy, search synaptic for restricted-modules, install the
>>package for your architecture (probably 'generic' or 'i386'), reboot, and
>>then it should be detected.
>>If you're on Dapper I suggest you reboot after removing ndiswrapper.
>>Once you've rebooted, check System>Administration>Networki
>>ng, and see if the
>>wireless card is listed. If there is an entry for wireless networking
>>then your card has been detected.
>>If the card is still not being detected, then I would first check that the
>>pcmcia card bus and other laptop doodads are working properly - search the
>>forums and the internet for linux on your particular computer.
>>You may want to try booting the kernal with options such as noapic or
>>acpi=off, to see if that works, the former was necessary on one of my
>>laptops for it to recognise the soundcard, wifi and pcmcia bus on hoary.
>>Once it's detected:
>>1. Turn off any security on your wireless network
>>2. Install network-manager and network-manager-gnome (assuming you're on
>>3. Restart Gnome. You should see a network icon in the top righthand.
>>it. Does it give you wireless network options? If so, sign onto your
>>4. Once you have it working, then you can enable the security, and network
>>manager will disconnect you and ask you for the WEP passphrase/whatever.
>>you are using WPA security, then you have to install some other packages,
>>search for that in the forums.
>>Hope that helps.

>ubuntu-ca mailing list
>ubuntu-ca at lists.ubuntu.com

Off to school, going on a trip, or moving? Windows Live (MSN) Messenger lets 
you stay in touch with friends and family wherever you go. Click here to 
find out how to sign up!  http://www.telusmobility.com/msnxbox/

More information about the ubuntu-ca mailing list