How to reconstruct GRUB for 14.04 on MBPro?

Fritz Hudnut este.el.paz at
Sun Oct 12 17:26:34 UTC 2014


Wondering if anybody could give me some hints to help get normal booting of
my 14.04 system?  Have a triple boot set up with two versions of OSX in
front of 14.04, which I access using rEFInd, which then loads GRUB.  Did a
system upgrade of OSX which has messed with rEFInd in the past . . . fixed
that, but, this time it seemed to mess with GRUB.  I tried the "Boot Repair
Drive" and it did its thing, but did not get me back into 14.  Using
SuperGrub 2 I can boot the system, and I ran "recovery mode" and went
through some of the listed items . . . that has not revived the GRUB item
so that normal booting can take place.

Had a thread posted on the main Ubuntu forum and got some suggestions, some
highly technical, sort of beyond my skill level, . . . did the
"update-grub" in the Terminal, etc . . . .  So, I can log in to 14 using
SG2 and access the system, I've got a number of added repos . . . if there
was a way to "re-install GRUB" w/o erasing and installing the whole system,
that would be appreciated.

PS:  When I use SG2 "detect grub cfg file" . . . it finds it, synaptic
shows that "grub2" is installed . . . something got wonky and isn't
"connecting" . . . .  Any thoughts?

F/ e.e.p.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Lubuntu-users mailing list