enigmail does not find gpg-agent in kde

Waleed Hamra kubuntu-users at whamra.com
Sat Dec 17 15:44:33 UTC 2011

On 17/12/11 13:48, Andre Massing wrote:
> Hi!
> Thanks for the quick reply!
> [snip]
>>>> gpg-agent should be started by X when it starts. you should
>>>> have a file called:
>>>> /etc/X11/Xsession.d/90gpg-agent
>>>> look for it, and see if it exists, this file is part of the 
>>>> gnupg-agent package.
>>> Yes, it exists and apt-file find /etc/X11/Xsession.d/90gpg-agent
>>> tells me the file is part of the gnupg-agent package as
>>> expected. Strangely, the gpg-agent starts i a gnome 3 session
>>> without any problems, and  corresponding environment variables as
>>> GPG_AGENT_INFO are set, not so in a KDE session. That is why I
>>> suspect that somehow the start up procedure in KDE does not
>>> involve (correctly) the gpg-agent..
>>>> another thing, what is the default login screen? kdm or gdm?
>>> I tried both and it failed in both. Thanks for the help so far..
>>> Are there any other places I could check ...?
>> maybe its just an environment variable issue. is gpg-agent
>> running? check with:
>> ps -A | grep gpg-agent
> I  checked that and it turned out that the gpg-agent is not running
> when I log into my KDE session.
> I also did a pristine installation of kubuntu 11.10 on a VM,
> installing all updates and thunderbird in combination with enigmail
> and I get the same problem: no gpg-agent running. That is kind of
> strange, I guess there quite some people out there using KDE/kubuntu +
> Thunderbird and gpg... And in addition thunderbird did not even
> recognize that enigmail is installed, manifesting in a missing openpgp
> menu..
> ATM I am rather clueless where to start, especially since it does not
> seem to be a prominent problem according to my google searches.
> But as always any hints and pointers are highly appreciated... And
> probably I should file a bug report if I haven't overlooked something
> rather obvious.

hmm... i did a fresh install of kubuntu 11.10 2 weeks ago, and things
worked fine. but maybe due to custom config files i copied from my home
open ~/.gnupg/gpg.conf in a text editor, create it if doesnt exist.
make sure it has the line:


alone on a line by itself. my file also has:

keyserver hkp://keys.gnupg.net

and were added by GPGConf as some comments in the file indicate.
then open the file ~/.gnupg/gpg-agent.conf

make sure it has some pinentry line, mine is:

pinentry-program /usr/bin/pinentry-qt4

hope this helps.

Waleed K. Hamra
Manager of Hamra Information Systems
Lead Technician at Illusion Computers Megastore

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 262 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/kubuntu-users/attachments/20111217/ca02e7ee/attachment.sig>

More information about the kubuntu-users mailing list