Can't get wireless to work with kubuntu 9.04

David McGlone david at
Fri Jul 31 11:49:09 UTC 2009

On Friday 31 July 2009 12:44:08 am Nils Kassube wrote:
> Bruce Bales wrote:
> > Wireless on my laptop with kubuntu 8.04 was not easy.  I had to
> > sudo iwconfig ath0 essid bbs key (the wep code)  and then
> > sudo dhclient each time I booted up.
> >
> > Then I upgraded to kubuntu 9.04 and the iwconfig line no longer
> > works.  The iwconfig line gives me "ath0 no such device."
> > I tried wlan0, wlan, eth0, ath1 and wlan1 -- same result.
> What wireless device do you have? I think "ath0" would be some Atheros
> chipset but which one? 8.04 had the madwifi driver but now the driver is
> in the kernel, maybe your chipset is not yet supported correctly? To
> find out what chipset you have, use the commands
> lspci
> sudo lshw -C network
> in a terminal and post the relevant part of the output. And if you want
> to find out the wireless interface name you can try the command
> ifconfig -a
> in a terminal. It will show you the configuration of all interfaces
> known to your system.
> > The main page has an icon which says "network management"  Clicking
> > on that then  "network connection" then "enable wireless"  then
> > "manage connection" gets me nowhere.
> If you have problems getting the network manager working it may be
> useful to replace it with wicd. You can install the wicd package from
> the 9.04 repository.

Another suggestion, check your /etc/network/interfaces. I can almost guarantee 
it's empty.

David M.

More information about the kubuntu-users mailing list