missing keyboard shortcut in mc 4.6.2-pre1 from kubuntu repo???

Constantinos Maltezos pandarsson at yahoo.com
Mon Jan 19 00:42:53 UTC 2009

On Sunday 18 January 2009 4:16:41 pm Joe(theWordy)Philbrook wrote:
> Since these same shortcuts do work in kubuntu if I run mc in one of
> the 6 virtual consoles. But (in kubuntu) they don't work from an either
> xterm or konsole, I have to think the problem isn't exactly with
> "konsole" and/or "xterm", but rather some other aspect of how kubuntu
> implements the gui must be interfering with these bindings...
> But I still don't have a clue how to fix it...

I don't know if you have an rc file for mc, but if you do, check it carefully.  
It might have special settings for running in X.  I know vi has some settings 
like that.

Something else to try: if you run Kopete, try starting a conversation with 
someone.  Type in a message and press ctrl+enter.  If it sends the message, 
then perhaps it's something like your keyboard layout.  If it starts a new 
line, then everything should be working properly.  If it does neither of these 
things, it occurs to me to ask if you have your ctrl key set up as a modifier 
for making special characters like with accents or umlauts over them.  If 
that's the case, you might want to either change it or use the other ctrl key.

By the way, you've tried using both ctrl keys at different times, right?

One last thing to try if all of the above is a waste: install another WM.  You 
don't need Gnome.  Try WindowMaker - that's a cool one.  Or IceWM.  I believe 
they're both in the package manager (I'm on a different machine at the moment, 
or I'd check).  Then open xterm there and see if it works.  If it does, then 
it's a setting in KDE.  If it doesn't, we go back to an X setting.  So if it 
doesn't, could you post the keyboard section of xorg.conf here?

More information about the kubuntu-users mailing list