missing keyboard shortcut in mc 4.6.2-pre1 from kubuntu repo???

Joe(theWordy)Philbrook jtwdyp at ttlc.net
Fri Jan 23 04:48:21 UTC 2009

It would appear that on Jan 18, Constantinos Maltezos did say:

> On Sunday 18 January 2009 4:16:41 pm Joe(theWordy)Philbrook wrote:
> > Since these same shortcuts do work in kubuntu if I run mc in one of
> > the 6 virtual consoles. But (in kubuntu) they don't work from an either
> > xterm or konsole, I have to think the problem isn't exactly with
> > "konsole" and/or "xterm", but rather some other aspect of how kubuntu
> > implements the gui must be interfering with these bindings...
> >
> > But I still don't have a clue how to fix it...
> I don't know if you have an rc file for mc, but if you do, check it carefully.  
> It might have special settings for running in X.  I know vi has some settings 
> like that.

That's a good suggestion. But the closest to an rc for mc that I'm
familiar with is ~/.mc/ini And I can't find anything like that there...
> Something else to try: if you run Kopete, try starting a conversation with 
> someone.  Type in a message and press ctrl+enter.  If it sends the message, 
> then perhaps it's something like your keyboard layout.  If it starts a new 
> line, then everything should be working properly.  If it does neither of these 
> things, it occurs to me to ask if you have your ctrl key set up as a modifier 
> for making special characters like with accents or umlauts over them.  If 
> that's the case, you might want to either change it or use the other ctrl key.

Ummm Kopete... That's one of those {gag} instant messaging tools
isn't it??? Got no use for it. Nor do I ever set up custom keyboard
layouts. I always select "us & english" for language and keyboard
configurations on installation. And then I don't mess with it.

> By the way, you've tried using both ctrl keys at different times, right?

Yeah, even though I don't mess with the keyboard layout, I've
occasionally found that some distro or other's default set-ups do treat
the right modifier keys differently than the left. So when a shortcut
doesn't work the first thing I try is the other matching modifier key.

> One last thing to try if all of the above is a waste: install another WM.  You 
> don't need Gnome.  Try WindowMaker - that's a cool one.  Or IceWM.  I believe 
> they're both in the package manager (I'm on a different machine at the moment, 
> or I'd check).  Then open xterm there and see if it works.  If it does, then 
> it's a setting in KDE.

Well maybe I should try to find another WM I can stand. But the main
reason I originally selected KDE (several years ago) was that I could
do almost everything without dusting of that {expletive deleted}
rodent. AND it was possible to change the default keyboard shortcuts
for ones that made sense to me... 

Would you happen to know of another WM that invests in the keyboard as a
primary input device?? 

Every time I look around I find that everything is supposed to be great
because of the "kool" way you just {censored} click on things to get
something done.

> If it doesn't, we go back to an X setting.  So if it 
> doesn't, could you post the keyboard section of xorg.conf here?

Well intrepid uses kde4 which has moved away from using the xorg.conf
file... But I get the same trouble with my hardy installation from
which I'll quote the keyboard section below. As far as intrepid goes
the best I know how to do this is to attach a snapshot of the Regional
& Language - System Settings >Keyboard Layout...

Or that is I would if kubuntu-users-bounces at lists.ubuntu.com didn't say:
=>  Message body is too big: 178723 bytes with a limit of 40 KB

So instead I offer a link that should point to the image file for at
least the next month or so...


<And now this from the xorg.conf of my kubuntu 8.04.1 hardy install ...>

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "us"

|    ^^^   ^^^
|    <o>   <o>	     Joe (theWordy) Philbrook
|	 ^    		  J(tWdy)P
|	___	       <<jtwdyp at ttlc.net>>
|      <sigh>

P.S.: I probably should confess that apparently I goofed when I said I
tested that the shortcut works in openSuSE's KDE environment. I don't
go there much and I must have tested it in a virtual console before I
knew that it might matter if the gui was up and running... It does
however work just fine in the KDE implemented by the Sabayon Linux
team. Which is currently my default boot choice (I can actually listen
to my music there... It's been a while since kubunto didn't fill up my
external speakers with too much background hiss to make it pleasurable
to sic kaffeine on my music file partition...) Kubuntu loads up quicker
for me however. So when I'm booting with only enough time to do some
task that I'm too focused on to want the gentle distraction of my
music, I usually boot kubuntu instead. Which is why this bugs me. I
spend just enough time using mc in Sabayon that the <ctrl>+<enter> &
<shift>+<ctrl>+<enter> shortcuts are so thoroughly second nature that
I windup having to reenter way too many incomplete command lines that
were executed by the shortcut with which I mearly intended to add a
pathname to it... <sigh>

More information about the kubuntu-users mailing list