Problems with KDE4 under Kubuntu Hardy

Rosalind Mitchell rcm at swimbarrow.co.uk
Fri May 30 23:16:05 BST 2008


On Friday 30 May 2008 22:15:58 Derek Broughton wrote:
> Splash screen, or Login screen?  It sounds to me as if you're getting to
> the KDM login screen, entering your username/password, the screen probably
> flashes a few times and then puts up the login screen again.

Yes, Login screen.  Sorry - [senior|blonde|pmt] moment.

> >> kdeinit4: PID 7199 terminated.
> >> Hangup
> >> GOT SIGHUP
> >> Could not connect to D-Bus server: org.freedesktop.DBus.Error.NoServer:
> >> Failed to connect to socket /tmp/dbus-lYPyTxiGsa: Connection refused
>
> I'm not sure how signifant this is - the Dbus error seems to be _after_ kde
> has already quit, but I'd want to look at that first, anyway.  It stands to
> reason that you'd have trouble if dbus isn't working.  Check the
> permissions on that socket first.  Is /usr/bin/dbus-daemon running?  Check
> syslog for other dbus errors.

enitharmon at scafell:~$ ps -aef | grep dbus
106       5340     1  0 12:59 ?        00:00:00 /usr/bin/dbus-daemon --system
dhcp      6342  5989  0 12:59 ?        
00:00:00 /sbin/dhclient -1 -lf /var/lib/d                    
hcp3/dhclient.eth0.leases -pf /var/run/dhclient.eth0.pid -q -e dhc_dbus=31 -d 
et                    h0
1000     21637     1  0 22:10 ?        
00:00:00 /usr/bin/dbus-daemon --fork --pr                    int-pid 
5 --print-address 7 --session
enitharmon at scafell:~$

Others *have* reported similar things: successful solutions for others have 
included 

* deleting the $HOME/.kde4 directory (didn't work for me)
* deleting /etc/kde4rc (didn't work for me)
* adding various system variable definitions to startkde (none of which worked 
for me)

None of these would really explain why the live CD won't start, except perhaps 
if there's something odd about my hardware, but although my box is a custom 
build I don't think there's anything unusual about it.

I have also installed KDE 4.04 from the backports.  Needless to say, this 
didn't work for me either!

At this rate, when Impudent Ibex (or whatever it's called) comes out, I shall 
have to resort to the wretched GNOME.  Aaaaargh!

Rosie



-- 
Currently reading: The Hours by Michael Cunningham
Enitharmon's Cave: http://enitharmon.wordpress.com
Pie & Mushies - Barrow Day by Day: http://pieandmushies.wordpress.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part.
Url : https://lists.ubuntu.com/archives/kubuntu-users/attachments/20080530/2c3df0ff/attachment.pgp 


More information about the kubuntu-users mailing list