Problems with kwin and kwallet.

Steven Vollom stevenvollom at
Tue Dec 9 04:37:49 UTC 2008

When kwallet asked for my password, I typed in the password and it did not 
accept the password.  I removed kwallet, re-booted the computer, and Kwin 
would not run.  I typed in kwin, and I got the window back, but it went away 
again.  When I pressed ctrl+f2, the window opened, however, the password 
would not type into the box.

I rebooted to repair, then ran the x ??repair option, then booted.  Kwin did 
not work, however, kontrole opened and the keyboard worked.  I typed in sudo 
apt-get autoremove to remove some unneeded packages, then sudo apt-get 
update.  The computer performed the update procedure, then suggested I do it 
again.  I ran sudo apt-get update again, this time it did not repeat the 
command.  When I continued the boot, my password was accepted and the 
computer opened.  Nonetheless, I did not have Kwin again.  I typed in kwin 
into the terminal and got Kwin back.  While I can still do stuff, I am making 
this post, in case I have difficulty getting to a workable desktop and am 
able to read incoming emails.

This mess happened, I think, because kwallet was not functioning properly.  I 
attempted to add the password for Kmail after I got it working and kwallet 
did not accept my sudo password.  I tried all the passwords I have thinking 
perhaps I set that password differently.  None worked.  I then removed 
kwallet, intending to reinstall, hopefully, a functioning package.  So I 
think removal of kwallet was what screwed things up.  Anyway, when I finish 
this post, I will attempt to configure kwallet once more.  Thanks for any 
input you may have or instructions.  I may have difficulty again.  The 
computer has not booted and worked properly since this set of problems began.


More information about the kubuntu-users mailing list