Tomcat 5.5 setup on Feisty

Greg Booth bootgr at
Mon Jun 25 17:59:03 UTC 2007


Ok, I give up. Usually googling here and there and checking forums I
can figure out how to do things on my own, but nothing seems to be
coming up.

I'm trying to get Tomcat5.5 loaded on my Feisty machine at home and it
doesn't seem to want to work right. I've got everything installed, the
sun JDK installed and configured using update-alternatives, put java
home in the default profile just in case and it's STILL not working.

Tomcat seems to start using /etc/init.d/tomcat55 start but when you
query it using /etc/init.d/tomcat55 status it says it's not running
and the web page on port 8080 that I have the server set to is not

I've got nothing in my logs showing ANYTHING. My only thought is maybe
it's permissions since the server runs under the tomcat55 user and
it's not owner on all the different directories created by the
install. It owns most of them but not all.

Any hints, tricks tips, thoughts I'd be happy to provide more details.
The only data I have is after I run /etc/init.d/tomcat55 start doing
ps -ef | grep tomcat I get the following:

jsvc.exec -user tomcat55 -cp
-outfile /var/lib/tomcat5.5/logs/catalina.out -errfile &1 -pidfile
/var/run/ -Djava.awt.headless=true -Xmx128M

I checked all the above directories, they're there, the pid file ( ) does NOT exist nor does it seem that the user would
have access to this directory.

Greg Booth

More information about the kubuntu-users mailing list