Wireless (madwifi) with wpa_supplicant freezes kernel

O. Sinclair o.sinclair at gmail.com
Tue Jul 24 07:20:29 BST 2007


Wafa Hakim Orman wrote:
> I'm running Kubuntu Feisty on a Toshiba Satellite laptop with a new
> Netgear WG115T wireless card that uses the Atheros chipset and Madwifi
> driver, both of which are _supposed_ to work seamlessly on Ubuntu. I
> bought the new wireless card because my old one, a Motorola with
> Broadcom chipset that needed ndiswrapper, could not work with my new
> workplace's dynamic WEP wireless with EAP/MSCHAPV2 authentication.
> (The card could, but only in Windows -- ndiswrapper, from everything I
> read, could not work with wpa_supplicant using dynamic WEP, and did
> not work with xsupplicant at all.)
> 
> Now, having installed the new driver, I've been having a series of
> problems & am _still_ unable to use the wireless here. It works on
> Windows so I know this is not a hardware issue.
> 
> The problems started when I tried to get Network Manager to use the
> dynamic WEP, but the interface only allowed WPA or static WEP. So I
> uninstalled Network Manager & replaced it with kwlan. My
> wpa_supplicant.conf has already been set up for the network; I just
> wanted a GUI to save me time when logging in. But kwlan almost
> inevitably caused the kernel to freeze, & nothing but a power-off &
> reboot would work. I googled the problem & it was suggested that
> people try the 386 kernel & not the generic kernel, since the generic
> was known to have issues. However, I never had the generic kernel --
> mine was always the 386. (I checked.) In addition, I had also
> uninstalled ndiswrapper, blacklisted it to be safe, & uninstalled the
> Broadcom drivers (& installed the madwifi drivers, to be safe.)
> 
> Finally I got so sick of it I uninstalled kwlan, leaving only the
> command-line wpa_supplicant. But now even that doesn't work. Merely
> starting up the laptop with the wireless card in it is enough to cause
> the kernel to freeze. It always freezes anyway if I dare to insert the
> wireless card while the computer is on.
> 
> 
> Does anyone know what is going on, & what I could do to fix it?
I am not in any way an expert on this but I got tired of quirks with 
Knetworkmanager and tried some alternatives such as Wlassistant. I 
finally stumbled on Wicd at http://wicd.sourceforge.net/
It takes a bit of tinkering to get up OK in KDE but once I got it 
working it has been "near perfect". This could be worth a try, it will 
completely remove (k)networkmanager but going back is not complicated 
should you wish to. Read the FAQ and the forums before you install.

Sinclair



More information about the kubuntu-users mailing list