fstab help with Hebrew VFAT partitions

Dotan Cohen dotancohen at gmail.com
Wed Feb 22 18:43:55 UTC 2006

When I first built my Kubuntu 5.10 system, I was able to mount a FAT32
partition that was used with Windows XP Home and contain Hebrew file
names with this fstab line:

/dev/hda6 /mnt/win_home vfat
umask=0111,dmask=0,codepage=862,iocharset=iso8859-8,rw,users 0 0

Now that I have converted my system to UTF-8, I can no longer read the
Hebrew file names on that partition. Instead of Hebrew letters, I get
squares. I have tried changing the encoding to:

and I have also tried without specifing the encoding. I have seen
absolutly no change. After I update fstab, I run "sudo mount -a". Is
that not supposed to remount all the filesystems? Would I be better
off restarting the machine after updating fstab? What other encodings/
other ideas can I try?

I should note that Hebrew file names in my /home/user directory show
fine, so I do not think that it is a font problem. Thanks in advance.

Dotan Cohen

More information about the kubuntu-users mailing list