k3b permissions error

Derek Broughton news at pointerstop.ca
Sat Dec 23 20:53:08 UTC 2006

mattflaschen wrote:

> Derek Broughton-2 wrote:

"2"???  I'm sure I'm the original :-)
>> When k3b says it can't open the device, click on the "Show debugging
>> output"
>> button - it's usually pretty obvious there what the problem is.
> Yes, that's what finally worked for me.  In my case, I didn't have
> permissions for /dev/sg0 .  I solved that elegantly (in my view) by
> creating a burning group (as recommended by K3B):
> $ sudo addgroup burning

Well, I just use cdrom - which is, after all, the owning group
for /dev/scd0.  The burning group may be a better idea if your system has
many users .
> Adding myself to it:
> $ sudo usermod -a -G burning matthew
> and setting the group of /dev/sg0 to burning:
> $ sudo chgrp burning /dev/sg0

Well, not too elegant I'm afraid - what do you do when you reboot?  /dev is
entirely in tmpfs, so it's rebuilt at boot.  Groups are set by udev.  I
filed a bug against udev, but Scott insists that it's an error in k3b or


More information about the kubuntu-users mailing list