Firestarter will not work

Derek Broughton auspex at
Fri Apr 15 12:21:50 UTC 2005

On Thursday 14 April 2005 18:47, hacker wrote:
> I was never able to get firestarter working either .. it may be too
> old for ubuntu's 2.6.x kernel (not sure).  I tried guarddog, but even
> had problems with it (could also be a 2.6 versus 2.4 kernel issue).  I
> don't know what to recommend (gui wise) .. I ended up going to
> and finding a script to use in my ip-up.d directory and
> it works just fine.

I used firestarter for a while, but it didn't deal well with the fact that my 
laptop's internet connection was sometimes eth0 and sometimes dpc0.  It's 
fine with 2.6 kernels though.

The only thing wrong with guarddog was that it's a gnome app :-)  It's what I 
use now.
> On 4/14/05, Peter Barnes <pjb at> wrote:
> > I'm (almost) new to Linux and tried the Kubuntu preview
> > version. I wanted a firewall and got a couple of
> > suggestions here. I installed Firestarter because it used a
> > GUI but I could not get it to work. So I decided to wait
> > until I had the 5.04 Kubuntu.
> >
> > Now I have that, and installed Firestarter but it still
> > doesn't work. I'm using a standard PC connected via a
> > router and broadband to the internet and through the router
> > to a Windows PC. Kubuntu can see the internet and the other
> > PC. When I try to start Firestater from Konsole I get the
> > wizard and a lot of lines in Konsole. On the internet page
> > of the wizard it offers me eth0 or ipv6, so i choose eth0
> > which sounds at least familiar. On the next page - network
> > - it offers the same. If I choose eth0 it tells me to go
> > away - I can't have the same for internet and network. If I
> > choose ipv6 it does not work - the firewall cannot set up
> > (and after googling I think ipv6 is irrelevant to me).

Of course you can't have the same interface for Internet and intranet (which 
is what it means by 'network').  I haven't used firestarter in so long, I 
can't tell you what options you have, but if you don't actually have a local 
network, there should be some kind of 'none' option.  As a last resort, 'lo' 
might work.
> >
> > Meanwhile....the lines have scrolled in Konsole - see
> > excerpts below this message. I've no idea what is wrong.
> > Error reading file /etc/firestarter/inbound/allow-from: No
> > such file or directory
If you never configured it, why would you expect any of its configuration 
files to exist?

More information about the kubuntu-users mailing list