edubuntu not connecting to internet

Gavin McCullagh gmccullagh at
Thu Mar 27 10:20:59 GMT 2008


On Wed, 26 Mar 2008, David Willmot wrote:

> I connected it to my router/switch before installing using the 10/100
> ethernet, leaving the 10/100/1000 free for the switch for the thin client
> side.

The two cards should be visible if you open a command line and do:


you should see a stanza beginning "eth0" and one beginning "eth1".  These
correspond to the two cards.  Can you give us the output of these commands.
You can also get more details on each one (including the speed) with:

	sudo /usr/sbin/ethtool  eth0

so you should be able from the speed to work out which one is which.  It
would be helpful to give us this output.  Finally, you might give us the
output of

	/sbin/route -n 

> Even though it shows the ip address of the switch ( as the dsl
> server it refuses to connect to the internet and so I can’t connect to
> repositories.

In the ifconfig command above, you should see that its address is something
like, or something up to  Try this

and press ctrl-c to stop it.  You need to make sure you get successful
pings something like this:

gavin at robin ~> ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=8.80 ms
64 bytes from icmp_seq=2 ttl=64 time=0.717 ms

> I’ve tried using dhcp for the port as well as changing it to a static ip
> address. I’ve also tried to use the 10/100/1000 port with the same settings
> but to no effect.

I'd suggest you use DHCP if the router is providing it.  You need to verify
it's working using the commands above though.

> Has anyone any thoughts as to how I connect it or how I download the apps
> from a repository in a sensible form to put on the machine.

If you have DSL, fix it and use the net :-)


More information about the edubuntu-users mailing list