Hardy Display problems

infiniti_guy infiniti_guy at ecorpsys.com
Wed Apr 23 19:33:10 BST 2008

I saw the change log form ubuntu4 and 5, and it definitely fixed an X
configuration issue that caused problems specifying a specific XServer
driver. I recommend you upgrade the ltsp-server. As I stated earlier,
though, I think there may be a problem with video playback under
LDM_DirectX=True mode, so this may not help entirely.

Charles Austin-2 wrote:
> On Wed, Apr 9, 2008 at 2:40 AM, Krsnendu dasa <krsnendu108 at gmail.com>
> wrote:
>> I have installed Hardy from Beta with all updates applied. I think I have
>> updated the ltsp tree once some time ago also.
>> I have a problem with display performance. Under K12ltsp6 (ltsp4.2) I had
>> tux maths, flash videos etc running well (and that was on an old system
>> (AMD
>> 2500XP with 2 GB RAM). I upgrade to Feisty on a Quad Core Intel machine
>> with
>> 4 GB RAM. Again Flash and other graphics was fine. Now I have installed
>> Hardy, screen redraws are slow even on ordinary web pages and Flash
>> videos
>> are especially jerky. (I have turned off hardware acceleration for
>> flash.)
> Are you running 32 bit or 64 bit version of the OS?  Flash is a real
> challenge in Gutsy 64 bit, but this is a Firefox issue.  I don't think
> it has been resolved yet.
>> I have LDM_DIRECTX=True.
>> I have tested it with echo $DISPLAY and directx seems to be working.
>> I suspect that the wrong driver is being used for the graphics card. I am
>> not sure which one.
>> If I do lspci on the client it says:
>> 01:00.0 VGA compatible controller : ATI Technologies Inc 3D Rage Pro
>> 1x/2X
>> (rev 5c)
>> I tried the following settings for xserver one by one:
>> XSERVER=vesa
>> XSERVER=ati
>> XSERVER=radeon
>> I also tried X_COLOR_DEPTH=16
>> Each time all I got was a black screen with a white dash flashing in the
>> top
>> left corner.
>> Using lsmod the only thing which seemed relevant was:
>> intel_agp 25492 1
>> agpgart 34760 1 intel_agp
> Where are you running lsmod - server or thin client?  (Can you run
> lsmod on the thin clients?)
> If the thin client has an intel video chipset, use XSERVER=intel.  I
> had the luxury of booting my thin clients as a thick client to find
> out what video drivers they were using.
>> When the xserver does start, I see this error when I press ALT-CTL-F1:
>> OIL: ERROR liboiltest.c 361: oil_test_check_impl(): illegal instruction
>> in
>> mmxCombineAddU
>> Can anyone give me advice how to troubleshoot my poor graphics
>> performance?
>> Should I try updating the ltsp image?
>> I think my current version is 2008212-ubuntu3. Perhaps version ubuntu4
>> will
>> fix my problem. Can I just do:
>> sudo chroot /opt/ltsp/i386/
>> sudo apt-get upgrade
>> sudo ltsp-client-build
> Don't do this from the chroot in Gutsy, if that is any help.
>>  Or do I have to start from scratch (delete /i386 directory then run
>> ltsp-build-client)?
> Shouldn't need to delete the i386 directory either.
>> Is there another graphics driver I need to load etc.?
>> Which log files can I look at? How can I export them to the server so I
>> can
>> look at them more easily and email them?
> Good question, anyone else know?
> Charles
> -- 
> edubuntu-users mailing list
> edubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/edubuntu-users

View this message in context: http://www.nabble.com/Hardy-Display-problems-tp16580555p16834749.html
Sent from the edubuntu-users mailing list archive at Nabble.com.

More information about the edubuntu-users mailing list