Hardy Display problems

infiniti_guy infiniti_guy at ecorpsys.com
Wed Apr 23 19:29:34 BST 2008

I too noticed that video playback in general was not good (jerky and skipping
frames in Flash and with MPlayer) with LDM_DirectX=True on Hardy. The
setting is supposed to help things by removing the encryption, but something
is not working right. Maybe one of the developers can comment on this? I
wonder if it is an amd64 OS with i386 clients issue? There seems to be
problems with this setup, as I suspect (but can not confirm) the developers
are running 100% i386 servers and clients. Or it could be there is a bug
with the LDM_DirectX configuration. But now that I see you have the same
problem, I think this is likely a bug.

Krsnendu Dasa wrote:
> I have installed Hardy from Beta with all updates applied. I think I have
> updated the ltsp tree once some time ago also.
> I have a problem with display performance. Under K12ltsp6 (ltsp4.2) I had
> tux maths, flash videos etc running well (and that was on an old system
> (AMD
> 2500XP with 2 GB RAM). I upgrade to Feisty on a Quad Core Intel machine
> with
> 4 GB RAM. Again Flash and other graphics was fine. Now I have installed
> Hardy, screen redraws are slow even on ordinary web pages and Flash videos
> are especially jerky. (I have turned off hardware acceleration for flash.)
> I have LDM_DIRECTX=True.
> I have tested it with echo $DISPLAY and directx seems to be working.
> I suspect that the wrong driver is being used for the graphics card. I am
> not sure which one.
> If I do lspci on the client it says:
> 01:00.0 VGA compatible controller : ATI Technologies Inc 3D Rage Pro 1x/2X
> (rev 5c)
> I tried the following settings for xserver one by one:
> XSERVER=vesa
> XSERVER=radeon
> I also tried X_COLOR_DEPTH=16
> Each time all I got was a black screen with a white dash flashing in the
> top
> left corner.
> Using lsmod the only thing which seemed relevant was:
> intel_agp 25492 1
> agpgart 34760 1 intel_agp
> When the xserver does start, I see this error when I press ALT-CTL-F1:
> OIL: ERROR liboiltest.c 361: oil_test_check_impl(): illegal instruction in
> mmxCombineAddU
> Can anyone give me advice how to troubleshoot my poor graphics
> performance?
> Should I try updating the ltsp image?
> I think my current version is 2008212-ubuntu3. Perhaps version ubuntu4
> will
> fix my problem. Can I just do:
> sudo chroot /opt/ltsp/i386/
> sudo apt-get upgrade
> sudo ltsp-client-build
> Or do I have to start from scratch (delete /i386 directory then run
> ltsp-build-client)?
> Is there another graphics driver I need to load etc.?
> Which log files can I look at? How can I export them to the server so I
> can
> look at them more easily and email them?
> All help appreciated.
> Thanks.
> Krsnendu dasa
> -- 
> edubuntu-users mailing list
> edubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/edubuntu-users

View this message in context: http://www.nabble.com/Hardy-Display-problems-tp16580555p16834746.html
Sent from the edubuntu-users mailing list archive at Nabble.com.

More information about the edubuntu-users mailing list