Customizing Edubuntu's LTSP client to start another session

S. J. van Harmelen svh at
Tue Oct 16 12:20:51 BST 2007

Thanks for your reply!

I already tried what you suggested, but without any luck. While the
client is flikkering all the time (seems like X restarting all the time)
it doesn't respond to ctrl+alt+F1.

So I did another test. I did a default ldm session and then tried to
manualy start /usr/lib/ltsp/screen.d/rdesktop. But this resulted in the
same behavior, and so I still could not check anything.

I find this rader strange though. The rdesktop script I'm trying to use
is file offert by Edubuntu it self. It's in the defult install off Gutsy
so I guess I should expect it to work out-of-the-box? Right?

So maybe this is a bug?

Any other things I can test/try? I'm willing to put in the time
nessesary, but I need some guidens.



  On Tue, 2007-10-16 at 10:15 +0100, Gavin McCullagh wrote:
> Hi,
> On Tue, 16 Oct 2007, S. J. van Harmelen wrote:
> > Is there nobody who can help me a bit with this? I'm trying al kind of
> > things, but I just don't get a rdesktop session going.
> > 
> > What can I do or try?
> You could set the root password on the client:
> Then press <ctrl><alt><F1> on the client and login.
> Run 
> 	ps aux | grep rdesktop
> to see if the command you wanted is really being run.
> You presumably have a script called
> 	/opt/ltsp/i386/usr/lib/ltsp/screen.d/rdesktop
> Can you make it log all output to a file, say /tmp/rdesktop.log and then
> inspect the file for errors.
> You could check the rdesktop server and see are any connections being
> refused or if any connection is coming in from the client (tcpdump would be
> a good bet for this).
> Gavin

More information about the edubuntu-users mailing list