Better name for dpush wanted

Stephen J. Turnbull stephen at
Wed Apr 29 20:28:57 BST 2009

Jelmer Vernooij writes:

 > bzr core provides "only" 61 visible commands of those 122.

Sure, but people are going to want plugins.  rebase, gtk, and bzrtools
are all pretty popular, and launchpad will become more so over time.

 > I agree that having a lot of commands can be overwhelming to
 > users. I don't see a lot of things that can be removed or would be
 > good candidates for merging though (bzr --no-plugins help
 > commands).

* Dramatic reduction possible for sure:

conflicts, deleted, ignored, ls, missing, renames -> ls
alias, nick, plugins, version, whoami -> config
clone -> <delete>
bind, checkout, pull, switch, unbind, update -> checkout
tag, tags -> tag[1]
init, init-repository -> init[2]
pull, merge, remerge -> merge[3]
uncommit, revert -> revert
info, revno, root, status -> status[4]

* There's gotta be some consolidation possible here:

break-lock, check, clean-tree, ignore, pack, reconcile, reconfigure,
    remove-tree, split, upgrade, version-info, view -> manage, info

I think you should fairly easily be able to reduce the number of core
commands to 40, with some effort, 35.

[1]  It's actually harmless to have both the singular and plural form
with the obvious semantics, but it's the principle of the thing.

[2]  Cf. my immediately previous post.

[3]  "pull" is a horrible name for "mirror" semantics.  Mostly it
belongs in checkout/update, some in merge.

[4]  "status" is not a great name for the information provided by
info, but it seems reasonably apt as a switch: "bzr status --branch",
for example, defaulting to --files.

More information about the bazaar mailing list