RFC: naming of the 'record' command in the loom plugin
p.f.moore at gmail.com
Mon Feb 25 20:21:21 GMT 2008
On 25/02/2008, John Arbash Meinel <john at arbash-meinel.com> wrote:
> | Anyone else have any opinions? Robert, do you have another suggestion
> | for how we should handle this?
> Well, bzr shelve solved it in a different way. It provides "bzr shelve" and "bzr
> unshelve" and all other operations are sub-commands. "bzr shelf
> It might be reasonable to use that for looms. I think Robert has already hooked
> into "bzr switch", which takes care of up/down-thread. So "bzr loom create"
> instead of create-thread.
While I haven't used the extension at all yet, I'm certainly
interested in it. I hate the hyphenated commands - I'd much rather
have simple one-word commands. I quite like the idea for using
subcommands like "bzr loom create".
As far as particular commands are concerned:
* loomify - I really dislike this command, it doesn't convey to me at
all what it is. I'd suggest "bzr loom init".
* record - I've no real problem with this, but "bzr loom commit"
seems to fit the scheme quite nicely.
* xxx-thread - Why not "bzr thread XXX"?
* revert-loom and show-loom - Could be "bzr loom revert" and "bzr loom show".
This reflects my preference for single word commands, and subcommands,
over multi-word-commands. Others may feel differently.
More information about the bazaar