[RFC] Remove bzrlib.branch.BzrBranchExperimental

John Arbash Meinel john at arbash-meinel.com
Mon Apr 16 16:33:11 BST 2007

Hash: SHA1

Martin Pool wrote:
> On 4/16/07, Robert Collins <robertc at robertcollins.net> wrote:
>> After the recent review where John got confused by
>> BzrBranchExperimental's difference to the other branch/branch formats, I
>> had a poke around and its not used anywhere nor does it have new
>> features. I've chatted with Martin and hes ok with it being removed.
>> Its intended to be part of a cleanup of how the Branch/BranchFormat
>> stuff works, but its currently incomplete, and crucially, not finished
>> nor ready as a base for folk to move forward on. I propose we remove it
>> until a fuller cleanup is done, where the code layout can stay
>> internally consistent.
> As Robert said, I don't mind removing it.
> Briefly, the thing I wanted to clean up is that at the moment we use
> Format classes, Format instances, Branch classes and Branch instances
> at different places, and this seems a bit redundant.  BranchFormat
> instances are generally stateless and more or less factories for
> getting Branches, and seem 1:1 with Branch classes, so why not just
> fuse them?

Because the "Branch" api is really large and confusing. And factoring
out some small portion of that into a helper class can decrease the
amount of functions one needs to search through to figure out what you
want to do.

This is more of a gut feeling than any hard and fast rule. I think we
need to start getting our api docs building so we can get a better
overview of how well our classes fit together. (I know we have a few
bogosities like "Branch.revision_history()" but "Branch.get_parent()", etc.)


Version: GnuPG v1.4.5 (Cygwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the bazaar mailing list