Tree Transform passing all tests, plus abuse

John A Meinel john at arbash-meinel.com
Sat Feb 18 03:42:05 GMT 2006


Aaron Bentley wrote:
> John A Meinel wrote:
> 
>>> Well, you said that you fixed the PEP8 issues of transform.py, and there
>>> are a whole lot of missing spaces. (Between classes, at the top, etc).
> 
> I've done more PEP8 stuff.
> 
>>> I certainly don't want to review Robert's changes along with yours.
> 
> Remember that diff -r ancestor:../robert is your friend.  Perhaps diff
> -r last-merge would be sweeter.

That would be nice. I've taken to just doing a 'bzr merge' and then 'bzr
diff' so that I can see how it applies to my tree.
It means I sometimes need to resolve conflicts. But it also means that
the revisions are being put into my local store, so that when I decide
I'm ready to actually do the merge, it doesn't take very long to pull
the changes.

> 
>>>>>>> I still don't have a good idea what changes to make here.
>>>>>> I think we just need to come up with a consistent naming convention.
> 
> Okay: how about
> 
> get_id_tree      -> trans_id_tree_file_id
> get_trans_id     -> trans_id_file_id
> get_tree_path_id -> trans_id_tree_path
> get_tree_file_id -> tree_file_id
> final_file_id    -> final_file_id (unchanged)
> inactive_file_id -> inactive_file_id (unchanged)
> 
> I haven't done this yet, but what do you think?

I feel like we need some sort of 'from' in there. like
'trans_id_from_tree_file_id'. Though it still isn't obvious what the
difference is between 'trans_id_tree_file_id' and 'trans_id_file_id'.

I also don't need the commands to be fully self documenting either.

What is the specific difference between the two above, and why can't we
just have a 'get_trans_id' which takes a file id, and returns a
transaction id.

Or maybe something like

get_tree_file_id => file_id_of()


> 
> Plus, I'm adding some docs on create_path vs create_file.
> 
>>> Eventually we will probably switch the display from using '/' to using
>>> '\' for certain cases of output to the user.
>>> However, I wanted everything internally consistent, before we deal with
>>> user presentation.
> 
> Okay, I've switched everything over to os.pathjoin
> 
>>> Stuff like bzr diff is going to use '/' since that means you can mail it
>>> to someone else.
> 
> (Even on Windows, some versions of patch require '/' as a separator.)
> 
> Aaron

Yeah. I felt that we should start with being universally '/' and then we
can change the output formatter as needed.

John
=:->

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 249 bytes
Desc: OpenPGP digital signature
Url : https://lists.ubuntu.com/archives/bazaar/attachments/20060217/9aa7ddd8/attachment.pgp 


More information about the bazaar mailing list