[xubuntu-users] unable to install grub

Clarence Fender leftystrat1 at gmail.com
Wed Feb 1 18:09:26 UTC 2023

Xubuntu 22.04 to laptop, USB boot (~2yrs old, linux-specific)
"something else" disk part
sda is where everything goes except HOME
sdb/nvm_etc  is /HOME

Unable to install GRUB in /dev/sda
Executing `grub-install /dev/sda` failed
fatal error
--> Can't fix this, no matter what I do.

Spent a long time researching: common problem going back years. Seems to
revolve around boot, legacy vs new. I haven't touched any boot settings.
Tried different partitions and flags. Tried using sda1 instead of sda -
same error.

sda   - all primary partitions
1M (appears by itself, no format)
500M  tried /BOOT and nothing
50G  ext4  /
16M swap
remainder of space ext4 but not mounted

sdb  ext4 /HOME

Is there a different sda partitioning I need? No data on it so no worries.
If I had hair, I'd be pulling it out.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/xubuntu-users/attachments/20230201/3d7f57af/attachment.html>

More information about the xubuntu-users mailing list