[xubuntu-users] problems with last 18.04

Nino R. Pereira ninorpereira at gmail.com
Thu Jan 17 14:41:14 UTC 2019

FYI I had a similar problem but with Ubuntu 16.04 and an Epson scanner 
Precision V39, which I got
because I had the same problem with my old trusty Canon scanner that 
stopped working when
I upgraded from 14 to 16 a few years ago. That problem I never solved, 
but I did get the V39 working.

The Ubuntu help and/or discussion lists tell you a few of the necessary 
I had to download 3 packages from the Epson web site: I don't remember 
their names any more,
otherwise I'd tell you. In addition I got iscan-bundle-1.0.0.x64.deb, 
iscan-gt-x770-bundle-1.0.0.x86.deb, and
imagescan-bundle-ubuntu-16.04-1.3.40.x64.deb. Probably only one of these 
is needed, but I played it

At first, none of them worked: all these scanner software started fine, 
but none could find the scanner.

In my case the solution was to diddle with the file that tells the 
computer where the scanner is located.
For  Epson,  this is in /etc/sane.d/epkowa.conf. This file is mostly 
comments and therefore surprisingly
helpful. For me the relevant part was
# For any USB scanner not known to the backend (yet), you may, at your
# own peril(!!), force the backend to recognise and use it via libusb.
# You can do so by the following configuration command:
#   usb <USB vendor ID> <USB product ID>

which is even (uncharacteristically explicit for linux) followed by an 
# SEIKO EPSON's USB vendor ID is '0x04b8' (without quotes), where
     the prefix 0x means 'hex'.

# The command 'lsusb' tells you these numbers: For my case, I get gives
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 04b8:013d Seiko Epson Corp.
Bus 002 Device 005: ID 03f0:3817 Hewlett-Packard LaserJet P2015 series

So I add to epkowa.conf the line

usb 0x04b8 0x013d

After doing this, it worked.

Now, the scanner software you use must know that it has to look at 
I don't quite follow how this works, but you should look in 
/etc/sane.d/dll.d, where the
different scanner packages get their information.  For example, iscan 
uses epkowa:

  cat /etc/sane.d/dll.d/iscan
# iscan -- enables the SANE backend(s) required
# Any changes to this file will be lost when upgrading iscan.


In addition, it tells you why your upgrade may not have worked: when you 
upgrade (iscan,
but by implication Ubuntu from 16 to 18) you may lose the reference to 



# A sample configuration for the Epson Perfection 1650 (Epson GT-8200),
# which has a product ID of 0x0110, would look as follows:
#usb 0x04b8 0x0110

On 1/17/19 2:44 AM, f6gal wrote:
> I'm using since a few years an DELL D630 and so D830.
> With 16.04, alla was OK but trying to install 18.04.
> No more wireless, and my EPSON V370 is NON operating. This canner is 
> reconized. EPSON DRIVERS installeds so but "simple scan and SANE" are 
> OUT.
> I comme back to 16.04. Is better !!!!
> Irenee PRAT F6GAL.

More information about the xubuntu-users mailing list