[xubuntu-users] Xubuntu on the Raspberry Pi 2/3/3B+

Adam Smith blondesaluki at gmail.com
Sun May 13 21:13:48 UTC 2018

> Hi Adam,
> today I have been trying to install the version under
> https://onedrive.live.com/?authkey=%21AN8MCHZJgb9DgG0&cid=78C0847849FED8F1&id=78C0847849FED8F1%21129&parId=root&action=locate
> I tried first with a USB stick with 2 partions (sudo fdisk/sdb1):
> 1 with 3 GB, type c ( W95 FAT32 (LBA) ) and bootable (a),
> 2) 5 GB same type
> then saved with w.
> ==> does not boot.
>        I found out in the meantime that I still need to have an SD card to
> boot the RPI, and have it point
>        to the USB stick, but I'd rather not use an USB stick at all.. (see
> further)
> I then prepared an sd card, 8 GB, with the same partioning,
> but one time with partition 2 as type 83 (Linux), and another as c (W95
> FAT32(LBA).
> I also tried making both partitions bootable, no change.
> ==> booted well in both cases
> BUT: when the installation asks for a disk to install on, nothing appears.
> It then turns back to a desktop version like a live disk one.
> I did have a message 'driver 'sdhost-cm2835' already registered.
> I opened the  the cmdline.txt file and changed"
> modprobe.blacklist=sdhci_iproc"  to "modprobe.blacklist=sdhost-bcm2835"
> but the message keeps coming back, and the disk for installation does not
> show.
> Any suggestion how I could use the same sd card for installation process
> AND the storing on 'disk' ?
> I use the RPI3 iin a small box and there is no place for a USB disk.  I
> have little space needs, and have a 64GB sd card in reserve..
> PS: the desktop seems to run well, except the firefox know issue.
> I am going to test if "skypeforlinux" can run on it..
> Brgds,
> Yvo.
Thanks for trying it out!

All 64bit capable Pi's are USB bootable.  With the Raspberry Pi 2 and
3B you have to set a one time programmable bit to turn it on, but with
the Pi3B+ it is on by default.  USB booting can be a bit flaky though,
I think a workaround is to put the bootcode.bin file on a sd card and
it should boot from USB regardless of whether you've set the OTP bit
or not.  Some pitfalls are using the wrong partition table and setting
the esp flag.  In both cases it definitely won't boot.  I think the
fat partition has to come first, but I'm not absolutely sure on that.

Alternatively, if you are really struggling to get usb boot working,
you can copy the bootloader and kernel/initrd files to a sd card.
Once the initrd is loaded, the casper Linux package searches for the
'cd rom' with the rest of the files and this will be mounted as
/cdrom.  The sd card can then be wiped by the installer.

The above makes it sound complicated, but the installer works just
like the installer on a normal computer.  So it is designed to be
booted on one device (e.g. usb fash drive) and to be installed on
another device (e.g. sd card or hard disk).  In the past I've used the
'toram' boot parameter to overcome this, but in xubuntu 18.04 it
doesn't seem to want to unmount the /cdrom drive even when this is
used.  That seems to be a generic bug?  I'm doubtful whether it would
work on the Pi anyway since it has so little ram.

If you only had a sd card and no usb flash drive, then you could
pre-partition the drive as you describe and I would of thought you
could of installed to the second partition.  It's been a while since
I've done that, but I think that should be possible?  Maybe I'm
getting confused with iso booting?

Generally you don't need to pre-partition the drive that you want to
install on (unless you want a specific partition layout).  The
installer takes care of all that.  Have a look in the preseed folder,
everything Pi related is in there.  I've commented everything so it
should be understandable.

The driver 'sdhost-cm2835' already registered error message can be
ignored.  I can't do anything more about that (I raised a bug with
patch weeks ago).

Does any of that make sense?


More information about the xubuntu-users mailing list