[xubuntu-users] Lost terminal text cursor when closing non-terminal window

Teresa e Junior teresaejunior at gmail.com
Sun Jan 7 01:03:37 UTC 2018

Em 06/01/2018 19:12, MR ZenWiz escreveu:
> On Sat, Dec 30, 2017 at 6:44 PM, Tigerwolf <tigerwolf at tigerden.com> wrote:
>> On Sat, 30 Dec 2017, MR ZenWiz wrote:
>>> I run Xubuntu 16.04 LTS on all my systems.  On my HP8740w laptop,
>>> occasionally when I do something (I'll explain below), the cursor focus on
>>> my terminal windows gets lost and I can't type anything in the terminal
>>> windows.
>> The vanishing cursor/malfunctioning terminals is also an issue with the Unix
>> console text terminals when using Ctl-Alt-F1 to -F6
> I believe I have found the problem.
> My home directory is encrypted on my laptop.  Whenever I go to access
> one of the subdirectories for the first time, the machine stops
> briefly while it decrypts what it needs to i norder to access the
> files.  While this is happening, the whole machine seems to stop.
> After a few seconds, everything comes back to life and processing continues.
> I suppose I need to be more patient (or use an SSD...).
> Thanks.
> MR

So this is the old unsolved case of the desktop freezing on I/O 
operations. I have tried so many different things, but this always comes 
back to bite me, no matter what disk scheduler I use, if I use a swap or 
not, how I set vm.dirty_*, etc.

Unfortunately, most kernel developers seem to use SSDs, so I don't think 
this will ever be fixed. In fact, it seems to have become a lot worse in 
more recent Linux versions. There were a few patches recently that were 
supposed to alleviate this problem (Linux 4.10, I think), but I haven't 
noticed any improvements at all.

More information about the xubuntu-users mailing list