[xubuntu-users] JEdit broken by upgrade

Brian b_lists at patandbrian.org
Wed Aug 29 11:48:00 UTC 2018


I make occasional use of JEdit in sending a large text file where the
recipient is limited to 13,000 character e-mails - JEdit gives me a
running character count of what's in the cut-and-paste buffer, very
convenient!

As part of either the upgrade to 18.04 OR an upgrade of 18.04 (i.e. I
can't remember whether JEdit has ever run successfully under 18.04 or
not) something has broken, and I get a yard or so of Java error
messages when I try to run JEdit from a terminal (see below).

I'm afraid Java is a total mystery to me. So is anyone capable of
deciphering this for me? I've tried purging JEdit and reinstalling it,
the installation works just fine, no error messages. I've tried
reinstalling all the Java stuff I can find through Synaptic, same
again, no errors. If you know as much about Java as I do, then I guess
a secondary question is whether anyone can successfully run JEdit
under 18.04?

OK, all the errors that I get are blow. Thanks for any assistance.


Brian.


> jedit
> 7:34:08 AM [main] [error] main: Exception in thread "main" 
> 7:34:08 AM [main] [error] main: java.awt.AWTError: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapper
> 7:34:08 AM [main] [error] main:  at java.desktop/java.awt.Toolkit.newAWTError(Toolkit.java:472)
> 7:34:08 AM [main] [error] main:  at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(Toolkit.java:488)
> 7:34:08 AM [main] [error] main:  at java.base/java.util.stream.ForEachOps$ForEachOp$OfRef.accept(ForEachOps.java:183)
> 7:34:08 AM [main] [error] main:  at java.base/java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:177)
> 7:34:08 AM [main] [error] main:  at java.base/java.util.HashMap$KeySpliterator.forEachRemaining(HashMap.java:1608)
> 7:34:08 AM [main] [error] main:  at java.base/java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:484)
> 7:34:08 AM [main] [error] main:  at java.base/java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:474)
> 7:34:08 AM [main] [error] main:  at java.base/java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:150)
> 7:34:08 AM [main] [error] main:  at java.base/java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:173)
> 7:34:08 AM [main] [error] main:  at java.base/java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
> 7:34:08 AM [main] [error] main:  at java.base/java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:497)
> 7:34:08 AM [main] [error] main:  at java.desktop/java.awt.Toolkit.loadAssistiveTechnologies(Toolkit.java:532)
> 7:34:08 AM [main] [error] main:  at java.desktop/java.awt.Toolkit.getDefaultToolkit(Toolkit.java:613)
> 7:34:08 AM [main] [error] main:  at java.desktop/java.awt.EventQueue.invokeAndWait(EventQueue.java:1342)
> 7:34:08 AM [main] [error] main:  at java.desktop/javax.swing.SwingUtilities.invokeAndWait(SwingUtilities.java:1480)
> 7:34:08 AM [main] [error] main:  at org.gjt.sp.jedit.GUIUtilities.showSplashScreen(GUIUtilities.java:1957)
> 7:34:08 AM [main] [error] main:  at org.gjt.sp.jedit.jEdit.main(jEdit.java:389)
> 7:34:08 AM [main] [error] main: Caused by: java.lang.ClassNotFoundException: org.GNOME.Accessibility.AtkWrapper
> 7:34:08 AM [main] [error] main:  at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:582)
> 7:34:08 AM [main] [error] main:  at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:190)
> 7:34:08 AM [main] [error] main:  at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
> 7:34:08 AM [main] [error] main:  at java.base/java.lang.Class.forName0(Native Method)
> 7:34:08 AM [main] [error] main:  at java.base/java.lang.Class.forName(Class.java:374)
> 7:34:08 AM [main] [error] main:  at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(Toolkit.java:485)
> 7:34:08 AM [main] [error] main:  ... 15 more
> brian at brian-ubuntu:~$ 





More information about the xubuntu-users mailing list