[xubuntu-users] CUPS imposing authentication where it's not wanted

Peter Flynn peter at silmaril.ie
Sat Mar 12 23:32:43 UTC 2016

This bug is many years old but appears still to be active (I'm using
Xubuntu 15.10).

The server in my study has a HP printer, which is available to my home
network without authentication. This has been working perfectly for years.

I just added the printer as a remote SAMBA printer on my laptop, letting
the ADD dialog of the Printers utility in All Settings. It browsed the
home net and found the printer and configured itself OK, but when I
tried printing, I got lots of these:

> E [12/Mar/2016:23:02:08 +0000] [Job 373] Session setup failed: NT_STATUS_LOGON_FAILURE
> E [12/Mar/2016:23:02:08 +0000] [Job 373] Tree connect failed (NT_STATUS_ACCESS_DENIED)

I went back and tried again, and clicked Verify under the authentication
dialog. To my surprise, it asked me for a username and password and
domain (for my server) which I have never set or used. The printer is
not in any group protected by password.

All the other (Mac, Win, Droid) computers in the house can print to this
printer just fine with no prompting for authentication. Why is Linux
getting it wrong? Where on earth is it getting the idea that
authentication is required?

I found and tried
which is recommended on many pages, but this had no effect.


More information about the xubuntu-users mailing list