[xubuntu-users] Updating - a couple of questions

David Walland davidwalland at googlemail.com
Fri Dec 5 07:34:55 UTC 2014

Thanks, Peter,

To answer as best I can what you have written:

My Wifi is WPA2 security.  What happened was that when I updated from 12.04
to 14.04, the system loaded the wrong drivers for the Broadcom wifi board
and I had to reload the correct one.  At this point, I discovered that the
system would not give me access to enter the wifi password - anywhere in
any part of the Applications menu.  It appeared that the programming for
this was either corrupt or absent.  Despite my years of experience in
searching on the Internet, I found no mention of this.  Broadcom wifi
boards are such a nuisance that I bought in a second-hand Intel equivalent
and fitted that.  I still couldn't get at the logon for wifi and continued
to have to link via ethernet cable.
Eventually, I decided to "cut the Gordian knot".  The wifi issue had only
ever happened on 14.04 so I reloaded 12.04, which has been pretty
consistent and was immediately able to access the wifi logon and use wifi

I then tried to update to 14.04 again and this is when I lost all access to
voluntarily update the machine.  It still pops up with the updater
automatically.  Presumably the interface is xfce, I don't do anything
clever, as while I have immense experience as a user and occasional
programmer from 1964 on, I'm still a newbie on Linux and making haste
slowly.  The previous time I loaded from this disc, I *did* have the
Software Updater in the Applications menu under System!

Thanks for the terminal command - I'm newbie enough not to have known that

I have no idea what programs these updates are for.  I haven't knowingly
loaded either of the two you mention.  Oddly the updates aren't greyed out,
they simply won't allow me to select them and come in the middle of a list
where every other update

 is ticked as selected.

I've used the terminal a fair bit, if by rote.  I'm still trying to get my
head round what all the commands mean and what they're actually doing.  I
can type them in with the best (aside from the odd finger trouble).  Yet
I've still to find where for example "apt-get" actually goes to look for
the "apt".  It's just assumed that I'd know - and I'm dopey enough not to.
I was last in the depths of computer hardware/architecture and control
systems in the early 1980s with the Acorn BBC B computer, when I used to
write chips for my own amusement.  Computer architecture has moved on
vastly since then, while I've married and moved up to levels where my
interactions with computers are strictly at the user level and the system
design level, and even then a secondary part of my duties.  This leaves me
floundering a bit, as the assumption that someone with my background would
even have had *time* to keep up with the massive architectural changes in
computers, is non-valid - at least in my case.  Hence my attempts to
understand what is going on and the strange blend of newbie and
experience.  Until I started with Xubuntu this year my only experience with
any Unix system was in 1981 with something called Xenix, all of which I
have long forgotten (except the name).


On 4 December 2014 at 22:03, Peter Flynn <peter at silmaril.ie> wrote:

> On 12/04/2014 07:45 PM, David Walland wrote:
> > I thought I'd sent this to the List but it doesn't seem to have got
> > through.
> It got distributed this time anyway.
> > I've tried to Google but can get no meaningful answers.
> Google can be useful, but phrasing the query takes practice and
> foreknowledge, as there are established ways of referring to things that
> need to be used (as you rightly note at the end).
> > I'm running an old Dell Latitude D620 Laptop with Xubuntu 64 bit (Core
> > Duo cpu).
> Interesting. I'm running a D810 and a D610 with 14.04 and Enlightenment.
> > I've been moving between 12.04 and 14.04 as I originally
> > found 14.04 stopped me from accessing my WiFi as it wouldn't let me get
> > to where I could put in my WiFi system password.
> What security is the network using? Did you mean:
> a. it found your network but didn't prompt for the password
> OR
> b. it prompted you for (eg) username, but the password was invisible
> > This has now resolved itself.
> Do you know if you did something that helped it to resolve?
> > Now it's doing (14.04) something similar with Update.  This works
> > happily automatically
> Do you mean it pops up "Software Updater" from time to time by itself?
> I just logged out of e17 and into xfce, and sure enough, there was a
> taskbar item for Software Updater.
> > but my access to run it as and when *I* want has
> > magically disappeared from everywhere on the Applications Menu.  It
> > *was* always on the "Systems" sub-menu.  Any idea how I can get this
> back?
> My System menu *does* have an entry for Software Updater. Are you using
> xfce or some other interface?
> > Secondly, when it does come up for automatic Updating, two items are
> > totally inaccessible to me on the list but always present.  Can anyone
> > explain why or how to get them to be available for updating?
> Can you expand on "inaccessible"? Do you mean greyed-out?
> > "Command-line driven interactive plotting program. No-X package"
> > and
> > "Command-line driven interactive plotting program. X package".
> You don't say what the names of the programs are; I'm guessing these are
> gnuplot-nox and gnuplot-x11.
> > If the update is needed surely it should be runnable, if it isn't why is
> > it there?
> One way to resolve these questions is to run the update from the command
> line. That way you remove the graphical layer between you and the
> program. Open a Terminal window and type
> sudo apt-get upgrade
> It will ask for your password: type it in (it will not show anything)
> and press Enter. This should list the pending updates: examine them for
> these two oddities. Some updates get held back (for a variety of
> reasons), and apt-get should list these separately. You can use Y or N
> to do the suggested upgrade or not.
> sudo apt-get dist-upgrade
> should upgrade everything, held over or not.
> ///Peter
> --
> xubuntu-users mailing list
> xubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/xubuntu-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/xubuntu-users/attachments/20141205/a52807b7/attachment.html>

More information about the xubuntu-users mailing list