[xubuntu-users] keyboard doesn't work with acpi on lenovo s10-3c

Cazador mihijoeldoctor at gmail.com
Fri Oct 18 19:56:38 UTC 2013

The problem:

When I run linux -i have tried diferent distros- on my netbook lenovo
s10-3c all keys are disabled, numlock, capslock... It's seems like keyboard
haven't power.

keyboard works perfectly in bios, in grub (or lilo), in windows, but not in

I try various linux kernels and upgrade BIOS up to 16 but keyboard doesn't

Possible solutions:


Responses #101 and #114 give solutions, but so far this has not work for me.

What's the last thing i did?

 I post my problem for the bug report, but its an old treath. So, here i
am, asking for your help as well.

My post:

> I think i'm doing every thing, but i still can't use my keyboard.
> Maybe there is something i'm missing beacause my poor English, i don't now.
> I'll describe step by step what i've done, so please, tell what i'm not
> doing (or doing wrong).
> 1.- copy driver file s10-3c-keybdrv-x86-64 to /bin directory
> 2.- execute on the terminal "chmod +x /bin/s10-3c-keybdrv-x86-64"
> 3.- add to /etc/rc.local string before exit 0 "/bin/s10-3c-keybdrv-x86-64"
> 4.- copy "s10-3c-keybdrv.c" to /sbin
> 5.- reboot
> But nothing happen.
> Please, i need your feedbak. Thanks.
> ps. sorry for my English.

Maybe you can help me. Thanks.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/xubuntu-users/attachments/20131018/1ca5c57b/attachment.html>

More information about the xubuntu-users mailing list