[xubuntu-users] update-manager not on any of the menus and can't be put, there? (Andy Proctor)

Mark Trickett tiberopoulos at gmail.com
Mon Nov 26 09:57:57 UTC 2012

Message: 1 Date: Sat, 24 Nov 2012 20:50:41 +0000 From: Andy Proctor 
<xubuntu.list at gpshelp.co.uk> To: xubuntu-users at lists.ubuntu.com Subject: 
Re: [xubuntu-users] update-manager not on any of the menus and can't be 
put there? Message-ID: <50B13321.9060406 at gpshelp.co.uk> Content-Type: 
text/plain; charset=ISO-8859-1; format=flowed On 24/11/12 18:56, Knute 
Johnson wrote:
>> On 11/24/2012 10:49 AM, Ralf Mardorf wrote:
>>> On Sat, 2012-11-24 at 08:53 -0800, Knute Johnson wrote:
>>>> On 11/23/2012 01:36 PM, Ralf Mardorf wrote:
>>>>> On Fri, 2012-11-23 at 20:48 +0000, Andy Proctor wrote:
>>>>>> On 23/11/12 14:07, Vincent Trouilliez wrote:
>>>>>>> On Thu, Nov 22, 2012 at 11:45 PM, Knute Johnson
>>>>>>> <ubuntu at knutejohnson.com> wrote:
>>>>>>>            If I go into the Settings Manager, select Main Menu,
>>>>>>> select
>>>>>>>            a submenu (in this case System) and then attempt to enable
>>>>>>>            the Software Updater (which is update-manager) program on
>>>>>>>            any of the menus it disables itself in a few seconds.
>>>>>>> I hit
>>>>>>>            the checkbox next to update-manager and a few seconds
>>>>>>> later
>>>>>>>            it un-checks.  Anybody know what I'm doing wrong?
>>>>>>> I don't think yo are doing anything wrong: I did a clean install of
>>>>>>> XUbuntu12.10 and appear to have the same problem !
>>>>>>> Actually it doesn't appear to have anything to do with the
>>>>>>> update-manager itself, as I tried enabling other items in the system
>>>>>>> menu and they too disable themselves a second after I check their
>>>>>>> boxes !
>>>>>>> Definitely a good case for a bug report IMHO ! :-/
>>>>>>> -- 
>>>>>>> Vince
>>>>>> Agree, I've tried what you said and have the same problem.
>>>>>> Andy
>>>>> Delete ~/.cache, I couldn't change fonts and e.g. even after editing
>>>>> Evolution's config I couldn't change anything, because Evolution and
>>>>> e.g. the appearance settings were used from the cache, even after
>>>>> rebooting.
>>>>> After deleting the cache, until now everything is ok.
>>>>> Hth,
>>>>> Ralf
>>>> That didn't work.  Do you need to be root to change menus?
>>> No, this can be done with user privileges.
>>> I did edit my menu with Alacarte (the app for "Main Menu") and I
>>> experienced that I couldn't edit all entries as wanted. I couldn't
>>> uncheck some, but delete them, I also couldn't add some apps that I
>>> deleted some time before to the same menu were they were before, instead
>>> I had to put them to the sub menu "Other", deleting the cache indeed
>>> didn't help.
>>> :(
>> I found a bug for this.  It is specific to Xubuntu.  alacarte writes
>> the menu file to the wrong name on Xubuntu.  I just copied my
>> ~/.config/menus/applications.menu file to xfce-applications.menu file
>> and it now works fine.
>> It is supposed to be fixed in R(can't remember) and they said there
>> was a fix in Quantal proposed but I can't find it there. The work
>> around is OK for now I guess.
>> Bug #1069207
>> Thanks,
> Dear Knute, this workaround solves it, many thanks! I look forward to
> the fix in a future release, till then all good!
> Andy
I ran into this just last night. I noticed that there's an update to 
Alacarte (the software that is the menu item editor in Xubuntu 12.10) 
and it's been accepted into Pre-Release Updates Proposed. So, in 
Software Sources/Updater, I enabled backports, ran an update, and it was 


More information about the xubuntu-users mailing list