[xubuntu-users] xwindow / xfcr crashing in 12.04?

newcontact at comcast.net newcontact at comcast.net
Sun Jun 24 13:07:55 UTC 2012

----- Original Message -----
From: Joshua O'Leary <joshua.oleary at btinternet.com>
To: xubuntu-users at lists.ubuntu.com
Sent: Sun, 24 Jun 2012 11:55:40 -0000 (UTC)
Subject: Re: [xubuntu-users] xwindow / xfcr crashing in 12.04?

On 24/06/12 12:51, Os Maleus wrote:
 On Sunday 24 June 2012 10:31:00
        xubuntu-users-request at lists.ubuntu.com wrote:> Message: 1> Date: Fri, 22 Jun 2012 16:07:06 +0000
        (UTC)> From: newcontact at comcast.net> To: xubuntu-users at lists.ubuntu.com> Subject: [xubuntu-users] xwindow / xfcr
        crashing in 12.04?> Message-ID:>
        <110202835.1377751.1340381226040.JavaMail.root at sz0149a.westchester.pa.mail.comcast.net>>         > Content-Type: text/plain;
        charset="utf-8"> > Hi,> I clean-installed xubuntu 12.04 two
        months ago, and everything is running perfect until last
        night.  I always turned off my machine every night to save
        electricity, but when I started up my desktop this morning
        xwindow and/or xfcr4 is not working properly (please see the
        enclosed screen shoot for an illustration)> >    * the titlebars of all the windows
        (terminal, firefox, any x-applications) are gone>   * previously I set the background of
        the xfce4 panel to be transparent; now it's solid>   * previously I set two workspace, but
        the workspace widget now shows just one, and it does not show
        any of the x-applications that is currently running (I did check
        settings-->workspace and its   says that I have two
        workspace, but under "name of workspace" it only says "1" -- it
        used to say "1" and "2", I believe)>   * I can no longer
        press-down-alt-and-right-click-mouse to change the size of an
        existing x-window>   * I used noscript in firefox, but when
        I right click the mouse to adjust permission, I do see the
        right-click menu but as soon as I move the mouse pointer the
        right-click menu is gone!  Interesting enough, I don't have this
        problem in google chrome>   * when I click on an x-window that's
        under another x-window, it no longer pops up to the top.> > These are the main issues I've noticed
        so far; there might be others I have not yet noticed.  You can
        see the first three issues in the enclosed screen shoot.> > I don't remember doing anything unusual
        last night before I turned off the machine -- it was a clean
        shutdown (via logout menu), I did check for system update and
        there was none.   But there were signs of x/xfc4 not working
        properly --  I used to have a xdaliclock clock running on the
        top left hand corner, but a couple of weeks ago that went
        haywire -- it started showing up literally in the middle of the
        screen!  It might have happened after a update but I did not
        keep track of it.  After fiddding with it it, I thought it was
        an issue with xdaliclock and I let it slided.  Maybe not...> > I tried to restart xfce4 but I couldn't
        figure out how to do that.  I do not mind deleting the current
        xfce profile/setting and redo that again, but I really can't
        afford the time to reinstall the machine (project deadline...)> > Any suggestions on what's the cause and
        how to fix it?  Right now the only way I can close an x-window
        is to ctrl-alt-F1 to console and kill it by hand, and the rest
        of the system is barely useable (for reasons I outlined above).> > I love xubuntu -- I will never go back
        to unity! -- your help is most appreciative.> > THANKS!> > Hi,  have had the problem under earlier versions
        of Xubuntu. Solved it somehow in the way that I was recreating
        my user profile or reinstalling xfce4. If this doesn't help, You
        should try to reinstall. This is not a general bug, but should
        be just an coincidently happening mistake during the
        installation. Most of all, if it was running on earlier releases
        of Xubuntu.  

    Chances are, there is just a problem with user config and no need to
    reinstall or edit user accounts. Just run

    rm -r ~/.config/xfce4

    to reset all of xfce's user-based settings.
Thanks for your reply.  I just

rm -r  ~/.config/xfce4

but the same problem remains (no title bar for windows, loss mouse focus...).

Since I first emailed the mailing list I noticed a couple of additional (symptoms of the) problems:  When I go to
   Settings --> Setting Manager --> Window Manager Tweaks
   Settings --> Setting Manager --> Window Manager
I got nothing!   These twos are the only ones not working.

The first reply suggests that I reinstall xfce4.  How would I do that --  e.g.  use ubuntu software center?  synaptic?



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/xubuntu-users/attachments/20120624/33b20f05/attachment.html>

More information about the xubuntu-users mailing list