[xubuntu-users] Lightdm killed during boot

Mark mhullrich at gmail.com
Wed Jul 4 00:52:20 UTC 2012

On Jun 20, 2012 4:59 AM, "Joshua O'Leary" <joshua.oleary at btinternet.com>
> On 20/06/12 12:25, MR ZenWiz wrote:
>> I recently upgraded my work desktop to use Xubuntu 12.04 (from Ubuntu
>> 10.10, complete fresh install).
>> This last Monday when I went in to work, all the machines were off (we
>> had a power outage over the weekend) and I had shut mine down on
>> Friday.
>> However, when I booted the machine, lightdm was killed during the boot
>> and it took me a reboot and some log scoping to figure out what
>> happened.  When I started lightdm from the console, everything went
>> fine.
>> I had to reboot again due to an update, and the same thing happened.
>> What would kill lightdm during startup but allow it to run thereafter?
>> Thanks.
>> MR Zenwiz
> You could try to reinstall lightdm, with "apt-get install --reinstall
lightdm", as root.
> If that still doesn't work, try removing it completely with "apt-get
purge lightdm", then
> "apt-get install xubuntu-desktop lightdm lightdm-gtk-greeter"
> Also take a look at your system logs - run dmesg to view the kernel ring
buffer, look at /var/log/syslog and also /var/log/lightdm/lightdm.log to
see what is causing it to fail. /var/log/xorg.0.log may also be useful.
Unfortunately none of that worked. Lightdm still gets killed during
startup, even after purge & reinstall.

The logs contain nothing revealing, only that it was killed. No reason, no

It also shows gdm killed by TERM - same as lightdm.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/xubuntu-users/attachments/20120703/cf4b50fb/attachment.html>

More information about the xubuntu-users mailing list