[xubuntu-users] gvim window icon missing

Ivo Jimenez ivojimenez at gmail.com
Thu Jun 19 23:19:39 UTC 2008


When I run gvim, the window doesn't show its icon (the one shown in the
menu), it shows the default 'application' icon (the cube in the window and
the 'ninja star' in the taskbar).

The command I invoke in order to run gvim is gvim. When I look for what gvim
is, I get the following:

 $ ll /usr/bin/gvim*
lrwxrwxrwx 1 root root 22 2008-05-28 14:22 /usr/bin/gvim ->

Then, gvim in alternatives:

 $ ll /etc/alternatives/gvim
lrwxrwxrwx 1 root root 18 2008-05-28 14:22 /etc/alternatives/gvim ->

And vim.gnome is a binary file.

So, in theory, if I put a file in /usr/share/pixmaps/ called vim.gnome.[png
| svg | xpm] the icon should appear, right?

The problem I'm having is that I don't get any icon for the window. I have
ubuntu on my desktop pc (I use xubuntu in my laptop) and when I open the
gvim app, the icon is there. I have tried putting a 48x48 icon png file for
vim.png, gtk-vim.png, gnome-vim.png, gtkvim.png, gnomevim.png and gvim.png.
None has worked.

This is really frustrating because I have two other applications that
doesn't get its icon assigned to it (they don't have one) and when I switch
tasks by pressing alt-tab its hard to get to the vim window.

Thanks in advance for your help
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/xubuntu-users/attachments/20080619/adbad69c/attachment.html>

More information about the xubuntu-users mailing list