[xubuntu-users] Cannot get X to run in Xubuntu 6.10

Herold Treibs treibs at srv.net
Sat May 5 05:46:24 UTC 2007


michael at michaelshiloh.com wrote:
> Please also post your Xorg errors, probably in something like
> /var/log/Xorg.log. If unsure, see what shows up from:
>
>     ls -lt /var/log | head
>
> I would guess that the configuration is choosing a resolution that is too high
> for your monitor. Find the specs for your LCD panel and check that against the
> specs the the graphics chip to see the maximum resolution that the
> combination will support. Then go into your xorg.conf file and remove (or
> comment out) all resolutions that are higher than this.
>
> For testing you may want to start with something very simple, like 640*480
> only, get that working, then slowly increase until you get to the maximum you
> figured above. That's usually how I do it, and often I find that the higher
> resolution had some error that I didn't spot. At the lower resolutions it's
> harder to run into errors because there is a much greater safety margin before
> you run into the limits.
>
> Michael
>
>
>
> On Tue, 6 Feb 2007, Daniel Bodanske wrote:
>
>   
>> First, check the MD5SUM of your disk to make sure that there are no
>> errors.Then, take a look at /etc/X11/xorg.conf under the video settings and
>> see what driver is being used.
>>
>> Posting the syslogs and xorg.conf should get someone who can help.
>>
>> Dan
>>
>> On 2/6/07, Herold Treibs <treibs at srv.net> wrote:
>>     
>>>  I am trying to make use of several ten year old Digital Venturis FX-2
>>>  computers, and it seemed like a good idea to install Xubuntu.  These
>>>  have 128 mb of RAM, and a 2 gb hard drive, and a Pentium cpu running at
>>>  166 MHz.  I installed Xubuntu 6.10 alternate i386.iso that I downloaded
>>>  from the Xubuntu website.  The installation did not seem to have any
>>>  problems.  However, when I try to run Xubuntu in graphical mode, after
>>>  an initial black and white graphics screen with the xfce xubuntu rodent,
>>>  the picture blanked out, a blinking cursor hung in the upper left side
>>>  of the monitor for a few seconds, and then the monitor went off.
>>>
>>>  I tried running Xubuntu several times, with the same results as above.
>>>  When I start it by selecting the "recovery" mode in GRUB, it runs in
>>>  command mode, evidently as bash in root.  But if I type startx, the
>>>  screen goes blank except for the blinking cursor for a few seconds in
>>>  the upper left corner, and then the monitor turns off, with the pilot
>>>  light going from green to alternating green and yellow, the same as what
>>>  happens if I just try to start in regular graphics mode..
>>>
>>>  After restarting Xubuntu in recovery mode, I looked at the syslog file
>>>  written in previous attempts.  I got about four instances of ":gdm[3375]
>>>  gdm_slave-xioerror_handler: Fatal x error - Restarting :0"  (The numbers
>>>  in the brackets varied.)
>>>  Then  I got "gdm[3368]: Failed to start x server several times in a
>>>  short time period; disabling display:0" and
>>>  "exiting on signal 15"
>>>
>>>  I see in the archives that someone had similar problems a few weeks ago,
>>>  but they had nvidia graphics.  These computers have S3 Trio64V2/GX
>>>  graphics chips on the motherboard.  At least formerly these chips were
>>>  supported by a number of Linux distributions, but I am wondering whether
>>>  they are supported by Xubuntu.  I tried running Damn Small Linux 3.2 as
>>>  a live CD, and that seems to work, so I think the hardware is ok.  Also,
>>>  I tried another one of the identical computers I have on hand, and it
>>>  behaved the same.
>>>
>>>  Does anyone have any idea on what I need to do to get xubuntu to run on
>>>  these computers?
>>>
>>>  Herold
>>>
>>>
>>>  --
>>>  xubuntu-users mailing list
>>>  xubuntu-users at lists.ubuntu.com
>>>  Modify settings or unsubscribe at:
>>>  https://lists.ubuntu.com/mailman/listinfo/xubuntu-users
>>>
>>>       
>
>   
I'm sorry to be so late in responding to your replies.  The old Venturis 
computer is at a remote location, and I do not get there very often.  
Thanks for your suggestions.
I finally solved the problem.  First, I installed Xubuntu 7.04 alternate 
when it was released.  It still did not run in graphics mode.  I had 
been suspecting that ACPI was causing a problem because of error 
messages, and had put "acpi=off" in GRUB, but I had put that statement 
on a separate line and got "unrecognized statement" or something like 
that.  Then I ran across a statement (I think in a recent book by Thomas 
called something like Beginning Ubuntu Linux) that said to put the 
"acpi=off" in the same line that starts with "kernel."  I added it to 
the end of the line (after entering "e" in two places, once to edit the 
xubuntu line and once to edit the line starting with "kernel"), and 
Xubuntu booted into graphics mode!  It looks good to get that old 
computer running.

Herold



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/xubuntu-users/attachments/20070504/6cd86af2/attachment.html>


More information about the xubuntu-users mailing list