[xubuntu-users] Cannot get X to run in Xubuntu 6.10

Herold Treibs treibs at srv.net
Tue Feb 6 07:22:27 GMT 2007

I am trying to make use of several ten year old Digital Venturis FX-2 
computers, and it seemed like a good idea to install Xubuntu.  These 
have 128 mb of RAM, and a 2 gb hard drive, and a Pentium cpu running at 
166 MHz.  I installed Xubuntu 6.10 alternate i386.iso that I downloaded 
from the Xubuntu website.  The installation did not seem to have any 
problems.  However, when I try to run Xubuntu in graphical mode, after 
an initial black and white graphics screen with the xfce xubuntu rodent, 
the picture blanked out, a blinking cursor hung in the upper left side 
of the monitor for a few seconds, and then the monitor went off.

I tried running Xubuntu several times, with the same results as above.  
When I start it by selecting the "recovery" mode in GRUB, it runs in 
command mode, evidently as bash in root.  But if I type startx, the 
screen goes blank except for the blinking cursor for a few seconds in 
the upper left corner, and then the monitor turns off, with the pilot 
light going from green to alternating green and yellow, the same as what 
happens if I just try to start in regular graphics mode..

After restarting Xubuntu in recovery mode, I looked at the syslog file 
written in previous attempts.  I got about four instances of ":gdm[3375] 
gdm_slave-xioerror_handler: Fatal x error - Restarting :0"  (The numbers 
in the brackets varied.)
Then  I got "gdm[3368]: Failed to start x server several times in a 
short time period; disabling display:0" and
"exiting on signal 15"

I see in the archives that someone had similar problems a few weeks ago, 
but they had nvidia graphics.  These computers have S3 Trio64V2/GX 
graphics chips on the motherboard.  At least formerly these chips were 
supported by a number of Linux distributions, but I am wondering whether 
they are supported by Xubuntu.  I tried running Damn Small Linux 3.2 as 
a live CD, and that seems to work, so I think the hardware is ok.  Also, 
I tried another one of the identical computers I have on hand, and it 
behaved the same.

Does anyone have any idea on what I need to do to get xubuntu to run on 
these computers?


More information about the xubuntu-users mailing list