snap artifacts

Willem Hobers whobers at
Sun Mar 25 08:06:50 UTC 2018

Testing Xubuntu 18.04.

With 18.04 come snap-packages. Using "Software" to install applications 
may result in installing the snap-version of the application.
Snap-versions come with artifacts which may lead to end user frustration 
and questions.
I know, because, well, I got some first hand frustration and questions ;-).

I came across the following:

- snap versions of applications can not get outside the user's home folder.
The result is that from within the snap-application one can't browse to 
places like network folders, or other partitions. I came across this 
using KeepassXC; I have the Keepass-database in a folder which is 
located in a folder outside my home-folder to be able to share it 
between my Xubuntu 16.04 and my Xubuntu 18.04 install. From within the 
snap-Keepass I could not even "see" that folder.
Installing the deb-version of Keepass solved the problem.

- icons of snap-versions of applications can't be "seen" by parts of 
"the system".
The result is that in stead of the icon being shown in certain places, a 
generic question-mark is shown. I came across this when I had installed 
VLC through Software. When clicking the pulseaudio-plugin a menu is 
shown with the applications that can be managed through the plugin-menu. 
VLC was shown, but its icon was a generic question mark. The VLC icon 
also did not show up in the notifier plugin, so I could not use that 
icon to get to the VLC menu.
Installing the deb-version of VLC solved the problem.

- installing snap-applications will result in obsolete folders in the 
home-folder of any non-english user profile.
Some snap-installs insist on generating all the standard folders like 
"Videos", "Documents", "Pictures" even though they are there already 
albeit in a local language. I have not used the snap-applications enough 
to be able to determine if these non-local folders are also used by the 
snap-applications. If so, then that would mean that documents could 
possibly turn up in either the localized version or the English version 
of the folder, or perhaps both. Surely a possible source for end user 

- snap-applications clutter listing of block device.
Snap-applications appear to reside in block devices, named loopX (where 
x is a number) of type loop. These devices show up when listing through 
lsblk[1]. This is quite a minor issue for now. But if all applications 
come in snap, the list from lsblk will be cluttered with what seem to me 
quite a few useless list items.

- in my experience: snap-applications are slow to start up.

Snap-technology may very well be a solution to some problem, but that 
solution does not seem to be something at my side of the user experience.

I am not ranting here, mind, I am just sharing information which I hope 
may be useful to others.
Also: English is not my own language.



loop1    7:1    0  81,6M  1 loop /snap/core/4110
loop2    7:2    0  93,5M  1 loop /snap/slack/5
loop3    7:3    0 118,4M  1 loop /snap/musescore/7
loop4    7:4    0  81,7M  1 loop /snap/core/4206
sda      8:0    0 238,5G  0 disk
├─sda1   8:1    0  60,1G  0 part
├─sda2   8:2    0     1K  0 part
├─sda3   8:3    0 144,2G  0 part /media/shared
├─sda5   8:5    0   3,9G  0 part
└─sda6   8:6    0  30,4G  0 part /

More information about the xubuntu-devel mailing list